summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Seo2021-11-07 17:44:50 +0900
committerStephen Seo2021-11-07 17:44:50 +0900
commit77d6e5440c1e305fbf7abf2673ecb66e8e5d85f2 (patch)
treed07100bf88b3366a3745c6c093c63f6511cbaa5b
parent77d29fc1c6a51767471eb6cd1f610d7d422a3d3b (diff)
downloadaur-77d6e5440c1e305fbf7abf2673ecb66e8e5d85f2.tar.gz
Update for Raylib 4.0.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
-rw-r--r--raylib_glfw.patch10
3 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb800f7de0b4..1de991befe55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-raylib
pkgdesc = Simple and easy to use game programming library (mingw-w64)
- pkgver = 3.7.0
+ pkgver = 4.0.0
pkgrel = 1
url = https://www.raylib.com
arch = any
@@ -12,10 +12,9 @@ pkgbase = mingw-w64-raylib
options = !strip
options = !buildflags
options = staticlibs
- source = raylib_3.7.0.tar.gz::https://github.com/raysan5/raylib/archive/3.7.0.tar.gz
+ source = raylib_4.0.0.tar.gz::https://github.com/raysan5/raylib/archive/refs/tags/4.0.0.tar.gz
source = raylib_glfw.patch
- md5sums = 006da62cd93b25b1b02b8e806b9d4342
- md5sums = 63cb5f70a8caf1f896465cab01f0d4fe
+ md5sums = 7b4ffb9d3b6a01806be21a7cd93e2c53
+ md5sums = ee6b877e9fca8e5e6df2f287204ab996
pkgname = mingw-w64-raylib
-
diff --git a/PKGBUILD b/PKGBUILD
index e7a664a12a29..3235261b73c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stephen Seo <seo.disparate@gmail.com>
pkgname=mingw-w64-raylib
-pkgver=3.7.0
+pkgver=4.0.0
pkgrel=1
pkgdesc="Simple and easy to use game programming library (mingw-w64)"
arch=(any)
@@ -14,13 +14,13 @@ backup=()
options=(!strip !buildflags staticlibs)
install=
source=(
- "raylib_${pkgver}.tar.gz::https://github.com/raysan5/raylib/archive/${pkgver}.tar.gz"
+ "raylib_${pkgver}.tar.gz::https://github.com/raysan5/raylib/archive/refs/tags/${pkgver}.tar.gz"
'raylib_glfw.patch'
)
noextract=()
md5sums=(
- '006da62cd93b25b1b02b8e806b9d4342'
- '63cb5f70a8caf1f896465cab01f0d4fe'
+ '7b4ffb9d3b6a01806be21a7cd93e2c53'
+ 'ee6b877e9fca8e5e6df2f287204ab996'
)
diff --git a/raylib_glfw.patch b/raylib_glfw.patch
index 461fc94d4fac..7a80ed5c01d3 100644
--- a/raylib_glfw.patch
+++ b/raylib_glfw.patch
@@ -1,12 +1,12 @@
Fixes issues with name conflicts building with external glfw
---- a/src/core.c
-+++ b/src/core.c
-@@ -195,7 +195,7 @@
-
+--- a/src/rcore.c
++++ b/src/rcore.c
+@@ -196,7 +196,7 @@
+
// Support retrieving native window handlers
#if defined(_WIN32)
- #define GLFW_EXPOSE_NATIVE_WIN32
+// #define GLFW_EXPOSE_NATIVE_WIN32
#include "GLFW/glfw3native.h" // WARNING: It requires customization to avoid windows.h inclusion!
-
+
#if defined(SUPPORT_WINMM_HIGHRES_TIMER) && !defined(SUPPORT_BUSY_WAIT_LOOP)