summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2015-06-10 18:54:36 +0200
committerkfg2015-06-10 18:54:36 +0200
commit008bcf690fd6e56258f7682f7cc58437bdabe9f5 (patch)
tree9eff3de8bd61d53801be0695c702c52e8ae78d2d
downloadaur-008bcf690fd6e56258f7682f7cc58437bdabe9f5.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77ed7f2b2f49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mingw-w64-rtmpdump
+ pkgdesc = Tool to download rtmp streams (mingw-w64)
+ pkgver = 20140918
+ pkgrel = 1
+ url = http://rtmpdump.mplayerhq.hu/
+ arch = any
+ license = GPL2
+ license = LGPL2.1
+ makedepends = mingw-w64-gcc
+ makedepends = git
+ depends = mingw-w64-crt
+ depends = mingw-w64-openssl
+ options = !strip
+ options = !buildflags
+ options = !makeflags
+ options = staticlibs
+ source = git://git.ffmpeg.org/rtmpdump#commit=a1900c3
+ md5sums = SKIP
+
+pkgname = mingw-w64-rtmpdump
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..560798cfaf07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
+pkgname=mingw-w64-rtmpdump
+pkgver=20140918
+pkgrel=1
+pkgdesc="Tool to download rtmp streams (mingw-w64)"
+arch=('any')
+url="http://rtmpdump.mplayerhq.hu/"
+license=('GPL2' 'LGPL2.1')
+depends=('mingw-w64-crt' 'mingw-w64-openssl')
+options=('!strip' '!buildflags' '!makeflags' 'staticlibs')
+makedepends=('mingw-w64-gcc' 'git')
+source=(git://git.ffmpeg.org/rtmpdump#commit=a1900c3)
+md5sums=('SKIP')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ for _arch in ${_architectures}; do
+ cp -r ${srcdir}/rtmpdump ${srcdir}/build-${_arch} && cd ${srcdir}/build-${_arch}
+ unset LDFLAGS CPPFLAGS
+ make CC=${_arch}-gcc LD=${_arch}-ld AR=${_arch}-ar SYS=mingw
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd ${srcdir}/build-${_arch}
+ unset LDFLAGS CPPFLAGS
+ make CC=${_arch}-gcc LD=${_arch}-ld AR=${_arch}-ar SYS=mingw prefix=/usr/${_arch} mandir=/usr/${_arch}/share/man DESTDIR="$pkgdir" install
+
+ ${_arch}-strip --strip-unneeded ${pkgdir}/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
+
+ rm ${pkgdir}/usr/${_arch}/bin/*.exe
+ rm -r ${pkgdir}/usr/${_arch}/{sbin,share}
+ done
+}