summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2016-01-24 16:06:16 +0100
committerkfg2016-01-24 16:06:16 +0100
commita14d10e9af34749a46914e17115486beff87f5c7 (patch)
tree7abc22af1a940b574fe0cdb50cdbd68200a194ef
parent008bcf690fd6e56258f7682f7cc58437bdabe9f5 (diff)
downloadaur-a14d10e9af34749a46914e17115486beff87f5c7.tar.gz
upgpkg: mingw-w64-rtmpdump 1:2.4.r96.fa8646d-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77ed7f2b2f49..3d544b84ad84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Jan 24 15:06:03 UTC 2016
pkgbase = mingw-w64-rtmpdump
pkgdesc = Tool to download rtmp streams (mingw-w64)
- pkgver = 20140918
+ pkgver = 2.4.r96.fa8646d
pkgrel = 1
url = http://rtmpdump.mplayerhq.hu/
arch = any
@@ -14,8 +16,8 @@ pkgbase = mingw-w64-rtmpdump
options = !buildflags
options = !makeflags
options = staticlibs
- source = git://git.ffmpeg.org/rtmpdump#commit=a1900c3
- md5sums = SKIP
+ source = git://git.ffmpeg.org/rtmpdump#commit=fa8646d
+ sha256sums = SKIP
pkgname = mingw-w64-rtmpdump
diff --git a/PKGBUILD b/PKGBUILD
index 560798cfaf07..a2523bff3577 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgname=mingw-w64-rtmpdump
-pkgver=20140918
+pkgver=2.4.r96.fa8646d
pkgrel=1
pkgdesc="Tool to download rtmp streams (mingw-w64)"
arch=('any')
@@ -9,10 +9,20 @@ license=('GPL2' 'LGPL2.1')
depends=('mingw-w64-crt' 'mingw-w64-openssl')
options=('!strip' '!buildflags' '!makeflags' 'staticlibs')
makedepends=('mingw-w64-gcc' 'git')
-source=(git://git.ffmpeg.org/rtmpdump#commit=a1900c3)
-md5sums=('SKIP')
+_commit='fa8646d'
+source=("git://git.ffmpeg.org/rtmpdump#commit=${_commit}")
+sha256sums=('SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd rtmpdump
+
+ _ver_name='2.4'
+ _ver_commit='c28f1bab7822de97353849e7787b59e50bbb1428'
+
+ echo "${_ver_name}.r$(git rev-list --count ${_ver_commit}..HEAD).${_commit}"
+}
+
build() {
for _arch in ${_architectures}; do
cp -r ${srcdir}/rtmpdump ${srcdir}/build-${_arch} && cd ${srcdir}/build-${_arch}
@@ -34,3 +44,4 @@ package() {
rm -r ${pkgdir}/usr/${_arch}/{sbin,share}
done
}
+# vim: ts=2 sw=2 et: