summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2021-04-03 20:29:57 +0800
committerpingplug2021-04-03 20:29:57 +0800
commit43dc270ec48f8476886fad2ed9cd2635fea11499 (patch)
treefbd2c9ce89581857eeb73be9ef1bc09fd4574876
parent1176a91c3bece60f87e75f9cc34ec7219caa4576 (diff)
downloadaur-43dc270ec48f8476886fad2ed9cd2635fea11499.tar.gz
strip more
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97669cf9d467..77a8e1d8df60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -106,6 +106,7 @@ package() {
# strip
strip --strip-all "${pkgdir}/${_prefix}/bin/"{cargo,rustc,rustdoc}
strip --strip-all "${pkgdir}/${_prefix}/lib/rustlib/x86_64-unknown-linux-gnu/bin/"*
+ strip --strip-all "${pkgdir}/${_prefix}/libexec/"*
strip --strip-unneeded "${pkgdir}/${_prefix}/lib/librustc"*.so
strip --strip-unneeded "${pkgdir}/${_prefix}/lib/rustlib/x86_64-unknown-linux-gnu/lib/"*.so
i686-w64-mingw32-strip --strip-unneeded "${pkgdir}/${_prefix}/lib/rustlib/i686-pc-windows-gnu/lib/"*.dll