summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2020-05-20 02:06:34 +0800
committerpingplug2020-05-20 02:06:34 +0800
commit6c06f5c5f8a85e128efa8fe6660688970a7806c6 (patch)
treef79b3931a91b34f25f49a56f3433fb956adf56f9
parent3a08030caf0f1d1ae6a4c5e50c13b5d61182d6b0 (diff)
downloadaur-6c06f5c5f8a85e128efa8fe6660688970a7806c6.tar.gz
tweak
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
-rw-r--r--mingw-config.toml2
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 766ab8272404..5d78c7c67463 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-rust
pkgdesc = Systems programming language focused on safety, speed and concurrency (mingw-w64)
pkgver = 1.43.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.rust-lang.org
arch = x86_64
license = MIT
@@ -12,13 +12,14 @@ pkgbase = mingw-w64-rust
makedepends = libffi
makedepends = perl
makedepends = python
+ makedepends = python2
makedepends = nodejs
makedepends = procps-ng
makedepends = cmake
depends = gcc-libs
depends = curl
depends = libgit2
- depends = mingw-w64-gcc
+ depends = mingw-w64-gcc>=10.1.0
optdepends = mingw-w64-wine: for cargo test support
noextract = rust-std-1.42.0-x86_64-unknown-linux-gnu.tar.xz
noextract = rustc-1.42.0-x86_64-unknown-linux-gnu.tar.xz
@@ -45,7 +46,7 @@ pkgbase = mingw-w64-rust
sha256sums = SKIP
sha256sums = fe7e40786f6e013d471f2f8ed51ba268611122065930a6d5a10bf20146997270
sha256sums = SKIP
- sha256sums = e9c533229ec32ef55606fde07d7830c54c8bb30d3a691bf5e19c3b709af47d18
+ sha256sums = 0a57780abcf05a5977d07ae2edd24c7e7daabe563ec5d15652bb9215ec1b0f7a
pkgname = mingw-w64-rust
diff --git a/PKGBUILD b/PKGBUILD
index 23f740e78e0c..4e7de72c68f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _cargo=0.43.0
pkgname=mingw-w64-rust
_prefix=opt/rust
pkgver=1.43.1
-pkgrel=1
+pkgrel=2
pkgdesc="Systems programming language focused on safety, speed and concurrency (mingw-w64)"
arch=('x86_64')
url="https://www.rust-lang.org"
@@ -20,13 +20,14 @@ license=('MIT' 'Apache' 'custom')
depends=('gcc-libs'
'curl'
'libgit2'
- 'mingw-w64-gcc')
+ 'mingw-w64-gcc>=10.1.0')
optdepends=('mingw-w64-wine: for cargo test support')
makedepends=('gdb'
'ninja'
'libffi'
'perl'
'python'
+ 'python2'
'nodejs'
'procps-ng'
'cmake')
@@ -47,11 +48,10 @@ sha256sums=('eb0a103c67c4565403d9e6f84a1c708982a5e9e5b3c0d831e4d6f6451795d106'
'SKIP'
'fe7e40786f6e013d471f2f8ed51ba268611122065930a6d5a10bf20146997270'
'SKIP'
- 'e9c533229ec32ef55606fde07d7830c54c8bb30d3a691bf5e19c3b709af47d18')
+ '0a57780abcf05a5977d07ae2edd24c7e7daabe563ec5d15652bb9215ec1b0f7a')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
backup=("opt/rust/cargo/config")
-PKGEXT=".pkg.tar.gz"
prepare() {
cd "rustc-${pkgver}-src"
@@ -83,7 +83,7 @@ package() {
export CFLAGS="-O2 -pipe -fno-plt -Wall -D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
export CXXFLAGS="-O2 -pipe -fno-plt -Wall -D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
# TODO: find a way to disable packaging
- DESTDIR="${pkgdir}" python ./x.py install
+ DESTDIR="${pkgdir}" python ./x.py install --keep-stage 0 --keep-stage 1
# license
install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"{rust,cargo}
diff --git a/mingw-config.toml b/mingw-config.toml
index 4b4085328059..3f1a5fdb768d 100644
--- a/mingw-config.toml
+++ b/mingw-config.toml
@@ -301,7 +301,7 @@ debug = false
# Number of codegen units to use for each compiler invocation. A value of 0
# means "the number of cores on this machine", and 1+ is passed through to the
# compiler.
-codegen-units = 1
+codegen-units = 0
# Sets the number of codegen units to build the standard library with,
# regardless of what the codegen-unit setting for the rest of the compiler is.