summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2018-06-11 17:37:23 +0800
committerpingplug2018-06-11 17:37:23 +0800
commitb3d0bf4fdc53ab7fd802ff34d69ea60dfb775c0e (patch)
tree3dbda43ea2533272c34b6577d416f7d7ddb7d764
parent4a64d93076d5b68456dd4668c9567ea2f7150021 (diff)
downloadaur-b3d0bf4fdc53ab7fd802ff34d69ea60dfb775c0e.tar.gz
use ninja, build lld
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--mingw-config.toml4
3 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8071b6a1bd15..813c9954065f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-rust
pkgdesc = Systems programming language focused on safety, speed and concurrency (mingw-w64)
pkgver = 1.26.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.rust-lang.org
arch = x86_64
license = MIT
@@ -9,6 +9,7 @@ pkgbase = mingw-w64-rust
license = custom
makedepends = rust
makedepends = gdb
+ makedepends = ninja
makedepends = libffi
makedepends = perl
makedepends = python2
@@ -29,7 +30,7 @@ pkgbase = mingw-w64-rust
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
sha256sums = a1202800bd5621f5cac027177904da0b964eb43b93606d3e4c7b342a9f7473b4
sha256sums = SKIP
- sha256sums = 8ab05c10084d8e2795aa9d5a954fb05913abc26033c1f9bbf564d0e495f043e4
+ sha256sums = 65445abc7b1f7c14896e05e5f147e56974e8ca0fde5aeed95e15adbd51951ae7
pkgname = mingw-w64-rust
diff --git a/PKGBUILD b/PKGBUILD
index 47098976f08f..24e2ae695456 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _pkgname=rust
pkgname=mingw-w64-rust
pkgver=1.26.2
-pkgrel=1
+pkgrel=2
pkgdesc="Systems programming language focused on safety, speed and concurrency (mingw-w64)"
arch=('x86_64')
url="https://www.rust-lang.org"
@@ -20,6 +20,7 @@ depends=('gcc-libs'
optdepends=('mingw-w64-wine: for cargo test support')
makedepends=('rust'
'gdb'
+ 'ninja'
'libffi'
'perl'
'python2'
@@ -30,7 +31,7 @@ source=("https://static.rust-lang.org/dist/rustc-${pkgver}-src.tar.xz"{,.asc}
"mingw-config.toml")
sha256sums=('a1202800bd5621f5cac027177904da0b964eb43b93606d3e4c7b342a9f7473b4'
'SKIP'
- '8ab05c10084d8e2795aa9d5a954fb05913abc26033c1f9bbf564d0e495f043e4')
+ '65445abc7b1f7c14896e05e5f147e56974e8ca0fde5aeed95e15adbd51951ae7')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
backup=("opt/${_pkgname}/cargo/config")
@@ -86,6 +87,7 @@ package() {
# strip
strip --strip-all "${pkgdir}/opt/${_pkgname}/bin/"{cargo,rustc,rustdoc}
+ strip --strip-all "${pkgdir}/opt/${_pkgname}/lib/rustlib/x86_64-unknown-linux-gnu/bin/"lld
strip --strip-unneeded "${pkgdir}/opt/${_pkgname}/lib/rustlib/x86_64-unknown-linux-gnu/lib/"*.so
strip --strip-unneeded "${pkgdir}/opt/${_pkgname}/lib/rustlib/x86_64-unknown-linux-gnu/codegen-backends/"*.so
i686-w64-mingw32-strip --strip-unneeded "${pkgdir}/opt/${_pkgname}/lib/rustlib/i686-pc-windows-gnu/lib/"*.dll
diff --git a/mingw-config.toml b/mingw-config.toml
index add5ab1e0d13..6911db941fcd 100644
--- a/mingw-config.toml
+++ b/mingw-config.toml
@@ -44,7 +44,7 @@ static-libstdcpp = true
# Tell the LLVM build system to use Ninja instead of the platform default for
# the generated build system. This can sometimes be faster than make, for
# example.
-ninja = false
+ninja = true
# LLVM targets to build support for.
# Note: this is NOT related to Rust compilation targets. However, as Rust is
@@ -337,7 +337,7 @@ wasm-syscall = false
# Indicates whether LLD will be compiled and made available in the sysroot for
# rustc to execute.
-lld = false
+lld = true
# =============================================================================
# Options for specific targets