summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2015-06-10 18:52:48 +0200
committerkfg2015-06-10 18:52:48 +0200
commit42bad6c613cdad2578aab24e71af69968782e03d (patch)
tree9bf0a37d70af14eed69095cd084dff25bfe57eac
downloadaur-42bad6c613cdad2578aab24e71af69968782e03d.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD44
-rw-r--r--testsuite.patch86
3 files changed, 155 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc73ef9e8193
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = mingw-w64-schroedinger
+ pkgdesc = An implemenation of the Dirac video codec in ANSI C code (mingw-w64)
+ pkgver = 1.0.11
+ pkgrel = 3
+ url = http://www.diracvideo.org/
+ arch = any
+ license = GPL2
+ license = LGPL2.1
+ license = MPL
+ license = MIT
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ depends = mingw-w64-crt
+ depends = mingw-w64-orc
+ options = !strip
+ options = !buildflags
+ options = !libtool
+ options = staticlibs
+ source = http://www.diracvideo.org/download/schroedinger/schroedinger-1.0.11.tar.gz
+ source = testsuite.patch
+ md5sums = da6af08e564ca1157348fb8d92efc891
+ md5sums = 0d6d1f8e78befde9bd04d7e93aed0b67
+
+pkgname = mingw-w64-schroedinger
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86143bf7da41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
+pkgname=mingw-w64-schroedinger
+pkgver=1.0.11
+pkgrel=3
+pkgdesc="An implemenation of the Dirac video codec in ANSI C code (mingw-w64)"
+arch=('any')
+url="http://www.diracvideo.org/"
+license=('GPL2' 'LGPL2.1' 'MPL' 'MIT')
+depends=('mingw-w64-crt' 'mingw-w64-orc')
+options=(!strip !buildflags !libtool staticlibs)
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+source=(http://www.diracvideo.org/download/schroedinger/schroedinger-$pkgver.tar.gz
+ 'testsuite.patch')
+md5sums=('da6af08e564ca1157348fb8d92efc891'
+ '0d6d1f8e78befde9bd04d7e93aed0b67')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd ${srcdir}/schroedinger-$pkgver
+ patch -Np1 < ../testsuite.patch
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ mkdir -p ${srcdir}/build-${_arch} && cd ${srcdir}/build-${_arch}
+
+ unset LDFLAGS CPPFLAGS
+ $srcdir/schroedinger-$pkgver/configure --prefix=/usr/${_arch} --host=${_arch}
+
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd ${srcdir}/build-${_arch}
+
+ make DESTDIR="$pkgdir" install
+ install -m644 -D ${srcdir}/schroedinger-$pkgver/COPYING.MIT "$pkgdir/usr/${_arch}/share/licenses/schroedinger/COPYING.MIT"
+ ${_arch}-strip -x -g ${pkgdir}/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
+ rm -r ${pkgdir}/usr/${_arch}/share/gtk-doc
+ done
+}
diff --git a/testsuite.patch b/testsuite.patch
new file mode 100644
index 000000000000..0977f4ef5917
--- /dev/null
+++ b/testsuite.patch
@@ -0,0 +1,86 @@
+diff -ru schroedinger-1.0.11/testsuite/Makefile.am patched/testsuite/Makefile.am
+--- schroedinger-1.0.11/testsuite/Makefile.am 2012-01-23 02:32:45.000000000 +0100
++++ patched/testsuite/Makefile.am 2013-06-15 16:21:17.920105217 +0200
+@@ -97,9 +97,10 @@
+ #wavelet_2d_CFLAGS = $(SCHRO_CFLAGS)
+ #wavelet_2d_LDADD = $(SCHRO_LIBS)
+ wavelet_2d_SOURCES = wavelet_2d.c
+-nodist_wavelet_2d_SOURCES = $(top_srcdir)/schroedinger/tmp-orc.c
++nodist_wavelet_2d_SOURCES = $(top_builddir)/schroedinger/tmp-orc.c
+
+ wavelet_max_gain_SOURCES = wavelet_max_gain.c
++nodist_wavelet_max_gain_SOURCES = $(top_builddir)/schroedinger/tmp-orc.c
+
+ wavelet_noise_2d_SOURCES = wavelet_noise_2d.c
+
+@@ -118,7 +119,7 @@
+ #quant_CFLAGS =
+ #quant_LDADD = -lm
+ quant_SOURCES = quant.c
+-nodist_quant_SOURCES = $(top_srcdir)/schroedinger/tmp-orc.c
++nodist_quant_SOURCES = $(top_builddir)/schroedinger/tmp-orc.c
+
+ #sort_CFLAGS = $(SCHRO_CFLAGS)
+ #sort_LDADD = $(SCHRO_LIBS)
+diff -ru schroedinger-1.0.11/testsuite/Makefile.in patched/testsuite/Makefile.in
+--- schroedinger-1.0.11/testsuite/Makefile.in 2012-01-23 03:06:41.000000000 +0100
++++ patched/testsuite/Makefile.in 2013-06-15 16:35:51.133250813 +0200
+@@ -283,7 +283,9 @@
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1)
+ am_wavelet_max_gain_OBJECTS = wavelet_max_gain.$(OBJEXT)
+-wavelet_max_gain_OBJECTS = $(am_wavelet_max_gain_OBJECTS)
++nodist_wavelet_max_gain_OBJECTS = tmp-orc.$(OBJEXT)
++wavelet_max_gain_OBJECTS = $(am_wavelet_max_gain_OBJECTS) \
++ $(nodist_wavelet_max_gain_OBJECTS)
+ wavelet_max_gain_LDADD = $(LDADD)
+ wavelet_max_gain_DEPENDENCIES = libschrotest.la $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
+@@ -599,8 +601,9 @@
+ #wavelet_2d_CFLAGS = $(SCHRO_CFLAGS)
+ #wavelet_2d_LDADD = $(SCHRO_LIBS)
+ wavelet_2d_SOURCES = wavelet_2d.c
+-nodist_wavelet_2d_SOURCES = $(top_srcdir)/schroedinger/tmp-orc.c
++nodist_wavelet_2d_SOURCES = $(top_builddir)/schroedinger/tmp-orc.c
+ wavelet_max_gain_SOURCES = wavelet_max_gain.c
++nodist_max_gain_SOURCES = $(top_builddir)/schroedinger/tmp-orc.c
+ wavelet_noise_2d_SOURCES = wavelet_noise_2d.c
+
+ #phasecorrelation_CFLAGS = $(SCHRO_CFLAGS)
+@@ -618,7 +621,7 @@
+ #quant_CFLAGS =
+ #quant_LDADD = -lm
+ quant_SOURCES = quant.c
+-nodist_quant_SOURCES = $(top_srcdir)/schroedinger/tmp-orc.c
++nodist_quant_SOURCES = $(top_builddir)/schroedinger/tmp-orc.c
+
+ #sort_CFLAGS = $(SCHRO_CFLAGS)
+ #sort_LDADD = $(SCHRO_LIBS)
+@@ -890,19 +893,19 @@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+ @am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(orc_test_CFLAGS) $(CFLAGS) -c -o orc_test-orc_test.obj `if test -f 'orc_test.c'; then $(CYGPATH_W) 'orc_test.c'; else $(CYGPATH_W) '$(srcdir)/orc_test.c'; fi`
+
+-tmp-orc.o: $(top_srcdir)/schroedinger/tmp-orc.c
+-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT tmp-orc.o -MD -MP -MF $(DEPDIR)/tmp-orc.Tpo -c -o tmp-orc.o `test -f '$(top_srcdir)/schroedinger/tmp-orc.c' || echo '$(srcdir)/'`$(top_srcdir)/schroedinger/tmp-orc.c
++tmp-orc.o: $(top_builddir)/schroedinger/tmp-orc.c
++@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT tmp-orc.o -MD -MP -MF $(DEPDIR)/tmp-orc.Tpo -c -o tmp-orc.o `test -f '$(top_builddir)/schroedinger/tmp-orc.c' || echo '$(srcdir)/'`$(top_builddir)/schroedinger/tmp-orc.c
+ @am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/tmp-orc.Tpo $(DEPDIR)/tmp-orc.Po
+-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$(top_srcdir)/schroedinger/tmp-orc.c' object='tmp-orc.o' libtool=no @AMDEPBACKSLASH@
++@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$(top_builddir)/schroedinger/tmp-orc.c' object='tmp-orc.o' libtool=no @AMDEPBACKSLASH@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o tmp-orc.o `test -f '$(top_srcdir)/schroedinger/tmp-orc.c' || echo '$(srcdir)/'`$(top_srcdir)/schroedinger/tmp-orc.c
++@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o tmp-orc.o `test -f '$(top_builddir)/schroedinger/tmp-orc.c' || echo '$(srcdir)/'`$(top_builddir)/schroedinger/tmp-orc.c
+
+-tmp-orc.obj: $(top_srcdir)/schroedinger/tmp-orc.c
+-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT tmp-orc.obj -MD -MP -MF $(DEPDIR)/tmp-orc.Tpo -c -o tmp-orc.obj `if test -f '$(top_srcdir)/schroedinger/tmp-orc.c'; then $(CYGPATH_W) '$(top_srcdir)/schroedinger/tmp-orc.c'; else $(CYGPATH_W) '$(srcdir)/$(top_srcdir)/schroedinger/tmp-orc.c'; fi`
++tmp-orc.obj: $(top_builddir)/schroedinger/tmp-orc.c
++@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT tmp-orc.obj -MD -MP -MF $(DEPDIR)/tmp-orc.Tpo -c -o tmp-orc.obj `if test -f '$(top_builddir)/schroedinger/tmp-orc.c'; then $(CYGPATH_W) '$(top_builddir)/schroedinger/tmp-orc.c'; else $(CYGPATH_W) '$(srcdir)/$(top_builddir)/schroedinger/tmp-orc.c'; fi`
+ @am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/tmp-orc.Tpo $(DEPDIR)/tmp-orc.Po
+-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$(top_srcdir)/schroedinger/tmp-orc.c' object='tmp-orc.obj' libtool=no @AMDEPBACKSLASH@
++@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$(top_builddir)/schroedinger/tmp-orc.c' object='tmp-orc.obj' libtool=no @AMDEPBACKSLASH@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o tmp-orc.obj `if test -f '$(top_srcdir)/schroedinger/tmp-orc.c'; then $(CYGPATH_W) '$(top_srcdir)/schroedinger/tmp-orc.c'; else $(CYGPATH_W) '$(srcdir)/$(top_srcdir)/schroedinger/tmp-orc.c'; fi`
++@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o tmp-orc.obj `if test -f '$(top_builddir)/schroedinger/tmp-orc.c'; then $(CYGPATH_W) '$(top_builddir)/schroedinger/tmp-orc.c'; else $(CYGPATH_W) '$(srcdir)/$(top_builddir)/schroedinger/tmp-orc.c'; fi`
+
+ mostlyclean-libtool:
+ -rm -f *.lo