summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Bart2019-08-06 18:32:18 -0300
committerEduardo Bart2019-08-06 18:32:56 -0300
commitc29a095f6e73647725359aea6737a750565e0fe0 (patch)
tree79943810a8761b3027821862df9c9a058336141d
parente9c15f28cb1b36580bbc3fd1ef0f51e00c3c250e (diff)
downloadaur-c29a095f6e73647725359aea6737a750565e0fe0.tar.gz
Revert to autotools instead of CMake
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36c383146882..9665970a60eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-sdl2
pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) (mingw-w64)
pkgver = 2.0.10
- pkgrel = 1
+ pkgrel = 2
url = http://libsdl.org
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 747f2ce713cd..14f9146444e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-sdl2
pkgver=2.0.10
-pkgrel=1
+pkgrel=2
pkgdesc='A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) (mingw-w64)'
license=('MIT')
url='http://libsdl.org'
@@ -19,7 +19,7 @@ build() {
for _arch in ${_archs[@]}; do
mkdir build-${_arch} -p
pushd build-${_arch}
- ${_arch}-cmake .. -DSDL_SHARED=ON -DSDL_STATIC=ON
+ ${_arch}-configure
make
popd
done
@@ -35,8 +35,8 @@ package() {
make DESTDIR="${pkgdir}" install
find "${pkgdir}/usr/${_arch}/bin" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
find "${pkgdir}/usr/${_arch}/lib" -name "*.a" -exec ${_arch}-strip -g {} \;
- cp "${pkgdir}/usr/${_arch}/lib/libSDL2-static.a" "${pkgdir}/usr/${_arch}/lib/libSDL2.a"
- #ln -s "/usr/${_arch}/bin/sdl2-config" "${pkgdir}/usr/bin/${_arch}-sdl2-config"
+ cp "${pkgdir}/usr/${_arch}/lib/libSDL2.a" "${pkgdir}/usr/${_arch}/lib/libSDL2-static.a"
+ ln -s "/usr/${_arch}/bin/sdl2-config" "${pkgdir}/usr/bin/${_arch}-sdl2-config"
popd
done
}