summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjazztickets2023-01-07 12:30:51 -0700
committerjazztickets2023-01-07 12:30:51 -0700
commit9fd0f9daac327bd2ed08978762dc289287eb7744 (patch)
tree69a86c35aca873099d8ef636e17ef2d2d93aaeb4
parent13e097608f427055366c945f9d581ad01499bd96 (diff)
downloadaur-9fd0f9daac327bd2ed08978762dc289287eb7744.tar.gz
2.20.1
use built-in freetype
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b907ff46203a..3f839e6be027 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = mingw-w64-sdl2_ttf
pkgdesc = A library that allows you to use TrueType fonts in your SDL applications (Version 2) (mingw-w64)
- pkgver = 2.0.15
+ pkgver = 2.20.1
pkgrel = 1
url = http://libsdl.org
arch = any
license = MIT
makedepends = mingw-w64-configure
depends = mingw-w64-sdl2
- depends = mingw-w64-freetype2
- depends = mingw-w64-bzip2
options = staticlibs
options = !strip
options = !buildflags
- source = http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-2.0.15.tar.gz
- sha256sums = a9eceb1ad88c1f1545cd7bd28e7cbc0b2c14191d40238f531a15b01b1b22cd33
+ source = https://github.com/libsdl-org/SDL_ttf/releases/download/release-2.20.1/SDL2_ttf-2.20.1.tar.gz
+ sha256sums = 78cdad51f3cc3ada6932b1bb6e914b33798ab970a1e817763f22ddbfd97d0c57
pkgname = mingw-w64-sdl2_ttf
-
diff --git a/PKGBUILD b/PKGBUILD
index 2219ec80a406..a663c16f526d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
+# Maintainer: jazztickets <jazztickets at gmail dot com>
pkgname=mingw-w64-sdl2_ttf
-pkgver=2.0.15
+pkgver=2.20.1
pkgrel=1
pkgdesc="A library that allows you to use TrueType fonts in your SDL applications (Version 2) (mingw-w64)"
arch=(any)
url="http://libsdl.org"
license=("MIT")
-depends=(mingw-w64-sdl2 mingw-w64-freetype2 mingw-w64-bzip2)
+depends=(mingw-w64-sdl2)
makedepends=(mingw-w64-configure)
options=(staticlibs !strip !buildflags)
-source=("http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-$pkgver.tar.gz")
-sha256sums=('a9eceb1ad88c1f1545cd7bd28e7cbc0b2c14191d40238f531a15b01b1b22cd33')
+source=("https://github.com/libsdl-org/SDL_ttf/releases/download/release-${pkgver}/SDL2_ttf-${pkgver}.tar.gz")
+sha256sums=('78cdad51f3cc3ada6932b1bb6e914b33798ab970a1e817763f22ddbfd97d0c57')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare () {
- cd "${srcdir}/SDL2_ttf-${pkgver}"
- # missing from archive ??
- curl -fSsLO http://hg.libsdl.org/SDL_ttf/raw-file/a86a6db70990/SDL2_ttfConfig.cmake
-}
-
build() {
cd "${srcdir}/SDL2_ttf-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure ..
+ LDFLAGS="-lssp" ${_arch}-configure ..
make
popd
done