summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 23:45:29 +0200
committerxantares2015-06-08 23:45:29 +0200
commitfe817e31b3b212880be5d1e6e5ae793069bc73f2 (patch)
tree0164dd6c16c33b23dd425274926f605a0ae6176f
downloadaur-fe817e31b3b212880be5d1e6e5ae793069bc73f2.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84dc41d20a45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-sdl2_ttf
+ pkgdesc = A library that allows you to use TrueType fonts in your SDL applications (Version 2) (mingw-w64)
+ pkgver = 2.0.12
+ pkgrel = 7
+ url = http://libsdl.org
+ arch = any
+ license = MIT
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-sdl2
+ depends = mingw-w64-freetype
+ depends = mingw-w64-bzip2
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-2.0.12.tar.gz
+ md5sums = 79787216b56cb4707f39d538f2225e00
+
+pkgname = mingw-w64-sdl2_ttf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af0c808d29d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=mingw-w64-sdl2_ttf
+pkgver=2.0.12
+pkgrel=7
+pkgdesc="A library that allows you to use TrueType fonts in your SDL applications (Version 2) (mingw-w64)"
+arch=(any)
+url="http://libsdl.org"
+license=("MIT")
+depends=(mingw-w64-sdl2 mingw-w64-freetype mingw-w64-bzip2)
+makedepends=(mingw-w64-configure)
+options=(staticlibs !strip !buildflags)
+source=("http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-$pkgver.tar.gz")
+md5sums=('79787216b56cb4707f39d538f2225e00')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/SDL2_ttf-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure \
+ --disable-sdltest \
+ --with-freetype-prefix=/usr/${_arch}
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/SDL2_ttf-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}