summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 23:45:19 +0200
committerxantares2015-06-08 23:45:19 +0200
commit27983eef279c40720489a34b948ad87a53261a9c (patch)
tree0ccbd4210d6f4c227218516598c4fe82bed95045
downloadaur-mingw-w64-sdl_mixer.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21949abae7cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mingw-w64-sdl_mixer
+ pkgdesc = A simple multi-channel audio mixer (mingw-w64)
+ pkgver = 1.2.12
+ pkgrel = 10
+ url = http://www.libsdl.org/projects/SDL_mixer
+ arch = any
+ license = zlib
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ depends = mingw-w64-sdl
+ depends = mingw-w64-libmikmod
+ depends = mingw-w64-libvorbis
+ depends = mingw-w64-smpeg
+ depends = mingw-w64-flac
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-1.2.12.tar.gz
+ md5sums = e03ff73d77a55e3572ad0217131dc4a1
+
+pkgname = mingw-w64-sdl_mixer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f64a9d55d4cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=mingw-w64-sdl_mixer
+pkgver=1.2.12
+pkgrel=10
+pkgdesc="A simple multi-channel audio mixer (mingw-w64)"
+arch=(any)
+url="http://www.libsdl.org/projects/SDL_mixer"
+license=("zlib")
+depends=(mingw-w64-crt mingw-w64-sdl mingw-w64-libmikmod mingw-w64-libvorbis mingw-w64-smpeg mingw-w64-flac)
+makedepends=(mingw-w64-configure)
+options=(staticlibs !strip !buildflags)
+source=("http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-$pkgver.tar.gz")
+md5sums=('e03ff73d77a55e3572ad0217131dc4a1')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/SDL_mixer-${pkgver}"
+ for _arch in ${_architectures}; do
+ export LIBMIKMOD_CONFIG=/usr/${_arch}/bin/libmikmod-config
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/SDL_mixer-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}