summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMladen Milinkovic2019-06-29 23:20:38 +0200
committerMladen Milinkovic2019-06-29 23:20:38 +0200
commit61b44b6b697acb3ebbe653343559017af989d46a (patch)
tree837036300fad02ca221f1d5be876b2209e3a4eab
downloadaur-61b44b6b697acb3ebbe653343559017af989d46a.tar.gz
5.45.0
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD43
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e0bf34a875e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mingw-w64-solid
+ pkgdesc = Hardware integration and detection (mingw-w64)
+ pkgver = 5.45.0
+ pkgrel = 1
+ url = https://community.kde.org/Frameworks
+ arch = any
+ groups = mingw-w64-kf5
+ license = LGPL
+ makedepends = mingw-w64-extra-cmake-modules
+ makedepends = mingw-w64-qt5-tools
+ depends = mingw-w64-qt5-base
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://download.kde.org/stable/frameworks/5.45/solid-5.45.0.tar.xz
+ source = http://download.kde.org/stable/frameworks/5.45/solid-5.45.0.tar.xz.sig
+ validpgpkeys = 53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB
+ sha256sums = ade2068f5d0affeff3599ef12b67b016a4518e3085863739f9b6e90685d4b09c
+ sha256sums = SKIP
+
+pkgname = mingw-w64-solid
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c98cdbbd9a8b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.log
+*.sig
+*.tar
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6a3eb3a098d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+_pkgname=solid
+pkgname=mingw-w64-$_pkgname
+pkgver=5.45.0
+pkgrel=1
+arch=(any)
+pkgdesc="Hardware integration and detection (mingw-w64)"
+license=("LGPL")
+depends=(mingw-w64-qt5-base)
+groups=(mingw-w64-kf5)
+makedepends=(mingw-w64-extra-cmake-modules mingw-w64-qt5-tools)
+options=(staticlibs !strip !buildflags)
+url="https://community.kde.org/Frameworks"
+source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/$_pkgname-${pkgver}.tar.xz"{,.sig})
+sha256sums=('ade2068f5d0affeff3599ef12b67b016a4518e3085863739f9b6e90685d4b09c'
+ 'SKIP')
+validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd $_pkgname-$pkgver
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir "build-${_arch}" && pushd "build-${_arch}"
+ ${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname#mingw-w64-}-$pkgver/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ rm -rf "$pkgdir/usr/${_arch}/share"
+ done
+}