summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-04-12 04:11:40 +0100
committerAlexandros Theodotou2019-04-12 04:11:40 +0100
commitd2b44b0f522f1696abc1e704d16148332b845852 (patch)
tree8a3bcd4a88d871c5e8a185b5c453fe761372de00
parent4e94bb2aab0a8b536e1ac33294c47c6adaadd933 (diff)
downloadaur-d2b44b0f522f1696abc1e704d16148332b845852.tar.gz
try again
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD42
2 files changed, 36 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc19a3d5f7b8..d3545a489dc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,10 @@ pkgbase = mingw-w64-sord
makedepends = mingw-w64-python
depends = mingw-w64-serd
depends = mingw-w64-pcre
+ options = !libtool
+ options = !strip
+ options = !buildflags
+ options = !makeflags
source = https://download.drobilla.net/sord-0.16.2.tar.bz2
source = https://download.drobilla.net/sord-0.16.2.tar.bz2.sig
validpgpkeys = 907D226E7E13FA337F014A083672782A9BF368F3
diff --git a/PKGBUILD b/PKGBUILD
index 8d258fb1c7d6..febc5fcf39db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,7 @@ url="https://drobilla.net/software/sord/"
license=('custom:ISC')
depends=('mingw-w64-serd' 'mingw-w64-pcre')
makedepends=('mingw-w64-python')
+options=('!libtool' '!strip' '!buildflags' '!makeflags')
source=("https://download.drobilla.net/${_pkgbase}-${pkgver}.tar.bz2"{,.sig})
sha512sums=('fe143c07ed18c15ffaf2461ca587df76e365a075f5d93f5eaa4c26196e0b1dd59d24d16e176de3664a2658377a2934083af5742c80884e8e7dd201dcaccb9698'
'SKIP')
@@ -27,12 +28,18 @@ prepare() {
}
build() {
- cd "${_pkgbase}-${pkgver}"
+ cd "${srcdir}"
for _arch in "${_architectures[@]}"; do
- CC="$_arch-gcc" LDFLAGS="-lm" python waf configure --prefix=/usr/"$_arch" #\
+ rm -rf build-${_arch}
+ cp -r "${_pkgbase}-${pkgver}" build-${_arch}
+ pushd build-${_arch}
+
+ CC="$_arch-gcc" python waf configure --prefix=/usr/"$_arch" #\
#--test
python waf build
+
+ popd
done
}
@@ -42,14 +49,29 @@ check() {
}
package() {
- cd "${_pkgbase}-${pkgver}"
- python waf install --destdir="$pkgdir"
- # license
- install -vDm 644 COPYING \
- "$pkgdir/usr/share/licenses/$_pkgbase/LICENSE"
- # docs
- install -t "$pkgdir/usr/share/doc/${_pkgbase}" \
- -vDm 644 {AUTHORS,NEWS,README}
+ cd "${srcdir}"
+
+ for _arch in "${_architectures[@]}"; do
+ pushd "build-${_arch}"
+
+ python waf install --destdir="$pkgdir"
+ # license
+ install -vDm 644 COPYING \
+ "$pkgdir/usr/share/licenses/$_pkgbase/LICENSE"
+ # docs
+ install -t "$pkgdir/usr/share/doc/${_pkgbase}" \
+ -vDm 644 {AUTHORS,NEWS,README}
+
+ # move DLL to bin directory
+ install -d $pkgdir/usr/${_arch}/bin
+ mv "$pkgdir"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin
+
+ # strip
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+
+ popd
+ done
}
# vim:set ts=2 sw=2 et: