summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-12-31 00:25:22 +0100
committerMichel Zou2021-12-31 00:25:22 +0100
commit7ee6150baba496fa5fce0dc1aa25c51e1f28ac85 (patch)
tree5ea79e15fed90a47049878974ed2d96767de8417
downloadaur-7ee6150baba496fa5fce0dc1aa25c51e1f28ac85.tar.gz
2.3.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c89be8937dd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mingw-w64-soundtouch
+ pkgdesc = An audio processing library (mingw-w64)
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = https://www.surina.net/soundtouch/
+ arch = any
+ license = LGPL2.1
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-crt
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = https://codeberg.org/soundtouch/soundtouch/archive/2.3.1.tar.gz
+ sha256sums = 42633774f372d8cb0a33333a0ea3b30f357c548626526ac9f6ce018c94042692
+
+pkgname = mingw-w64-soundtouch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35d13362eb1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=mingw-w64-soundtouch
+pkgver=2.3.1
+pkgrel=1
+pkgdesc='An audio processing library (mingw-w64)'
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' '!strip' 'staticlibs')
+arch=('any')
+url='https://www.surina.net/soundtouch/'
+license=('LGPL2.1')
+source=(https://codeberg.org/soundtouch/soundtouch/archive/${pkgver}.tar.gz)
+sha256sums=('42633774f372d8cb0a33333a0ea3b30f357c548626526ac9f6ce018c94042692')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare () {
+ cd "$srcdir"/soundtouch
+}
+
+build() {
+ cd "$srcdir"/soundtouch
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ CXXFLAGS="-msse2" ${_arch}-cmake ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/soundtouch/build-${_arch}
+ make install DESTDIR="${pkgdir}"
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
+