summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAsterios Dimitriou2018-12-03 23:22:32 +0200
committerAsterios Dimitriou2018-12-03 23:22:32 +0200
commitd7f5910c1d3a5ee56ab5988dc1bf5ceb1c2d06b2 (patch)
tree8bcf617b858ae12a134f770b92b1be1ca86f39d7
parent3883ee80854be05162e238d7b283332b2c871c0c (diff)
downloadaur-d7f5910c1d3a5ee56ab5988dc1bf5ceb1c2d06b2.tar.gz
Upstream update to 4.0.0
Enable more features
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce27b057d89b..e779b37133fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-sqlcipher
pkgdesc = SQLite extension that provides transparent 256-bit AES encryption of database files (mingw-w64)
- pkgver = 3.4.2
+ pkgver = 4.0.0
pkgrel = 1
url = https://www.zetetic.net/sqlcipher/
arch = any
@@ -13,11 +13,8 @@ pkgbase = mingw-w64-sqlcipher
options = !strip
options = staticlibs
options = !makeflags
- source = sqlcipher-3.4.2.zip::https://github.com/sqlcipher/sqlcipher/archive/v3.4.2.zip
- source = https://www.zetetic.net/sqlcipher/verify/3.4.2/sqlcipher-3.4.2.zip.sig
- validpgpkeys = D83F5F9EB811D6E6B4A0D9C5D1FA3A2A97ED25C2
- sha256sums = f2afbde554423fd3f8e234d21e91a51b6f6ba7fc4971e73fdf5d388a002f79f1
- sha256sums = SKIP
+ source = sqlcipher-4.0.0.zip::https://github.com/sqlcipher/sqlcipher/archive/v4.0.0.zip
+ sha256sums = b02e18287d9bf43064fcbd0be07eb2a88af5c17342c3f95cf824688cb3e3fe39
pkgname = mingw-w64-sqlcipher
diff --git a/PKGBUILD b/PKGBUILD
index 33e401a3ddaa..09466d9a9f5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=sqlcipher
pkgname=mingw-w64-sqlcipher
-pkgver=3.4.2
+pkgver=4.0.0
pkgrel=1
pkgdesc="SQLite extension that provides transparent 256-bit AES encryption of database files (mingw-w64)"
arch=('any')
@@ -11,29 +11,32 @@ license=('BSD')
makedepends=('mingw-w64-configure' 'tcl')
depends=('mingw-w64-crt' 'mingw-w64-openssl')
options=(!buildflags !strip staticlibs !makeflags)
-source=("${_pkgname}-${pkgver}.zip::https://github.com/${_pkgname}/${_pkgname}/archive/v${pkgver}.zip"
- "https://www.zetetic.net/${_pkgname}/verify/${pkgver}/${_pkgname}-${pkgver}.zip.sig")
-sha256sums=('f2afbde554423fd3f8e234d21e91a51b6f6ba7fc4971e73fdf5d388a002f79f1'
- 'SKIP')
-validpgpkeys=('D83F5F9EB811D6E6B4A0D9C5D1FA3A2A97ED25C2') # Zetetic LLC <support@zetetic.net>
+source=("${_pkgname}-${pkgver}.zip::https://github.com/${_pkgname}/${_pkgname}/archive/v${pkgver}.zip")
+sha256sums=('b02e18287d9bf43064fcbd0be07eb2a88af5c17342c3f95cf824688cb3e3fe39')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare(){
cd "${srcdir}/${_pkgname}-${pkgver}/"
sed -i 's/lemon /lemon\$(BEXE)/g' Makefile.in
+ sed -i 's/mksourceid\$(BEXE)/mksourceid /g' Makefile.in
}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}/"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- CFLAGS="-DSQLITE_HAS_CODEC" \
+ CFLAGS="-DSQLITE_HAS_CODEC -DSQLITE_ENABLE_COLUMN_METADATA" \
LDFLAGS="-lcrypto" \
config_TARGET_EXEEXT=.exe \
${_arch}-configure \
--enable-tempstore \
--disable-tcl \
+ --enable-session \
+ --enable-fts3 \
+ --enable-fts5 \
+ --enable-json1 \
+ --enable-rtree \
..
make
popd