summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2023-09-19 19:01:27 +0200
committerMichel Zou2023-09-19 19:01:27 +0200
commitb2945515d3bf2e3a26cc059693a7f697cdfa97fe (patch)
tree94a8d2b4f29e87965dacc3c98f5b65cd4d70420a
parent730c558c963d4ea2240bb95321148db47613879d (diff)
downloadaur-b2945515d3bf2e3a26cc059693a7f697cdfa97fe.tar.gz
7.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7e94a9cd6b6..1cbbad9f9a51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-suitesparse
pkgdesc = A collection of sparse matrix libraries (mingw-w64)
- pkgver = 7.1.0
+ pkgver = 7.2.0
pkgrel = 1
url = https://people.engr.tamu.edu/davis/suitesparse.html
arch = any
@@ -11,7 +11,7 @@ pkgbase = mingw-w64-suitesparse
options = !buildflags
options = !strip
options = staticlibs
- source = https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v7.1.0.tar.gz
- sha256sums = 4cd3d161f9aa4f98ec5fa725ee5dc27bca960a3714a707a7d12b3d0abb504679
+ source = https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v7.2.0.tar.gz
+ sha256sums = ce63c34f566d0aeae3c85fdc5b72d293f7e834d10ec0a0417b4c0823ce6c0474
pkgname = mingw-w64-suitesparse
diff --git a/PKGBUILD b/PKGBUILD
index faff59a6e79c..ae9e27a4d590 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-suitesparse
-pkgver=7.1.0
+pkgver=7.2.0
pkgrel=1
pkgdesc="A collection of sparse matrix libraries (mingw-w64)"
url="https://people.engr.tamu.edu/davis/suitesparse.html"
@@ -9,13 +9,15 @@ makedepends=('mingw-w64-cmake')
license=('GPL')
options=('!buildflags' '!strip' 'staticlibs')
source=("https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v${pkgver}.tar.gz")
-sha256sums=('4cd3d161f9aa4f98ec5fa725ee5dc27bca960a3714a707a7d12b3d0abb504679')
+sha256sums=('ce63c34f566d0aeae3c85fdc5b72d293f7e834d10ec0a0417b4c0823ce6c0474')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
_subdirectories="SuiteSparse_config Mongoose AMD BTF CAMD CCOLAMD COLAMD CHOLMOD CXSparse LDL KLU UMFPACK RBio SuiteSparse_GPURuntime GPUQREngine SPQR SPEX GraphBLAS"
prepare () {
cd "$srcdir"/SuiteSparse-${pkgver}
+ # https://github.com/DrTimothyAldenDavis/SuiteSparse/issues/408
+ curl -L https://github.com/DrTimothyAldenDavis/SuiteSparse/commit/f3c9f8dd.patch | patch -p1
}
build() {
@@ -28,7 +30,7 @@ package() {
for _subdir in ${_subdirectories}; do
cd "$srcdir/SuiteSparse-${pkgver}/${_subdir}"
mkdir -p build-${_arch} && cd build-${_arch}
- LDPRELOAD= ${_arch}-cmake -DNPARTITION=1 -DBLA_VENDOR=Generic -DCMAKE_STAGING_PREFIX="$pkgdir"/usr/${_arch} ..
+ LDPRELOAD= ${_arch}-cmake -DNPARTITION=1 -DBLA_VENDOR=Generic -DCMAKE_STAGING_PREFIX="$pkgdir"/usr/${_arch} -DHAVE_GETENV_HOME=0 ..
make install
done
rm "${pkgdir}"/usr/${_arch}/bin/*.exe