summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-08-04 18:56:52 +0200
committerMichel Zou2020-08-04 18:56:52 +0200
commite745f5ff5ee4d7fc83e9cc922bc2fd4acf8e9581 (patch)
tree7e623f0f95eb603def5729edf8f0dc0a52a27583
downloadaur-e745f5ff5ee4d7fc83e9cc922bc2fd4acf8e9581.tar.gz
1.5.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..182a6cd31bc3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-svt-hevc
+ pkgdesc = The Scalable Video Technology for HEVC Encoder (SVT-HEVC Encoder) is an HEVC-compliant encoder library core. (mingw-w64)
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/OpenVisualCloud/SVT-HEVC
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-cmake
+ makedepends = yasm
+ depends = mingw-w64-crt
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = https://github.com/OpenVisualCloud/SVT-HEVC/archive/v1.5.0.tar.gz
+ sha256sums = 5331213ce3fe73d5fe2887cf3aabcd8ffde2fafd0e5f09928d412dc8306f3992
+
+pkgname = mingw-w64-svt-hevc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3d2354e51c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=mingw-w64-svt-hevc
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="The Scalable Video Technology for HEVC Encoder (SVT-HEVC Encoder) is an HEVC-compliant encoder library core. (mingw-w64)"
+arch=('any')
+url="https://github.com/OpenVisualCloud/SVT-HEVC"
+license=('GPL')
+depends=(mingw-w64-crt)
+makedepends=('mingw-w64-cmake' 'yasm')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("https://github.com/OpenVisualCloud/SVT-HEVC/archive/v${pkgver}.tar.gz")
+sha256sums=('5331213ce3fe73d5fe2887cf3aabcd8ffde2fafd0e5f09928d412dc8306f3992')
+
+_architectures="x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir/svt-hevc"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DCMAKE_BUILD_TYPE='Release' ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/svt-hevc/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}