summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-10-30 17:46:45 +0100
committerMartchus2016-10-30 17:46:45 +0100
commit220c02c0863f0deac79fa797b0f8517c9fd24eb3 (patch)
tree386c96f8c72dbd7c3932dcdaeae0fa582dd54e4f
parent321b417b26a9c8d910bbdf0ea56a36c25b55a777 (diff)
downloadaur-220c02c0863f0deac79fa797b0f8517c9fd24eb3.tar.gz
Update to 0.0.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e0849ec1f17..52053d161c3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Oct 3 12:25:54 UTC 2016
+# Sun Oct 30 16:46:42 UTC 2016
pkgbase = mingw-w64-syncthingtray
pkgdesc = Tray application for Syncthing (mingw-w64)
- pkgver = 0.0.2
+ pkgver = 0.0.3
pkgrel = 1
url = https://github.com/Martchus/syncthingtray
arch = any
@@ -11,17 +11,19 @@ pkgbase = mingw-w64-syncthingtray
makedepends = mingw-w64-cmake
makedepends = mingw-w64-qt5-tools
makedepends = ffmpeg
+ makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-crt
depends = mingw-w64-qt5-svg
depends = mingw-w64-qtutilities
depends = mingw-w64-openssl
depends = mingw-w64-qt5-base
+ optdepends = mingw-w64-qt5-base-static: use of static library
options = !buildflags
options = staticlibs
options = !strip
options = !emptydirs
- source = syncthingtray-0.0.2.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.0.2.tar.gz
- sha256sums = 311731a3541c31e4f98209a1f42460f13ebf4b5e4e5d1270a8768b9daac54862
+ source = syncthingtray-0.0.3.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.0.3.tar.gz
+ sha256sums = d542adf2d612e81ba9d26ae235b9f902d1d8c747ac4dece938122d285e1841f7
pkgname = mingw-w64-syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index 4f1a93048da0..05ceede823f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _webview_provider=none
_reponame=syncthingtray
pkgname=mingw-w64-syncthingtray
_name=${pkgname#mingw-w64-}
-pkgver=0.0.2
+pkgver=0.0.3
pkgrel=1
arch=('any')
pkgdesc='Tray application for Syncthing (mingw-w64)'
@@ -21,9 +21,14 @@ depends=('mingw-w64-crt' 'mingw-w64-qt5-svg' 'mingw-w64-qtutilities' 'mingw-w64-
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('311731a3541c31e4f98209a1f42460f13ebf4b5e4e5d1270a8768b9daac54862')
+sha256sums=('d542adf2d612e81ba9d26ae235b9f902d1d8c747ac4dece938122d285e1841f7')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+[[ $NO_STATIC_LIBS ]] ||
+ makedepends+=('mingw-w64-qt5-base-static') \
+ optdepends+=('mingw-w64-qt5-base-static: use of static library')
+ _configurations='-DENABLE_STATIC_LIBS:BOOL=ON'
+[[ $NO_SHARED_LIBS ]] && _configurations+=' -DDISABLE_SHARED_LIBS:BOOL=ON'
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
@@ -33,6 +38,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr/${_arch}" \
-DWEBVIEW_PROVIDER="${_webview_provider}" \
+ ${_configurations} \
../
make
popd