summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-11-04 17:01:58 +0100
committerMartchus2018-11-04 17:01:58 +0100
commitb27231ba00e1d6ea957aab60444773ded1828d6e (patch)
tree7fc0643d01eeafb88ac4924e22645e39ec03c114
parent39ee9eef5c1d87d0455bddbd87104fb1790686e4 (diff)
downloadaur-b27231ba00e1d6ea957aab60444773ded1828d6e.tar.gz
Update version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f57df4b48f1e..8f3ca1c9694b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-syncthingtray
pkgdesc = Tray application for Syncthing (mingw-w64)
- pkgver = 0.8.2
+ pkgver = 0.8.3
pkgrel = 1
url = https://github.com/Martchus/syncthingtray
arch = any
@@ -18,8 +18,8 @@ pkgbase = mingw-w64-syncthingtray
options = staticlibs
options = !strip
options = !emptydirs
- source = syncthingtray-0.8.2.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.8.2.tar.gz
- sha256sums = 34ebc32c78bfc2c6ebba390e78dafc32e6eddbac7e613ab3b4573f79cb1c01b2
+ source = syncthingtray-0.8.3.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.8.3.tar.gz
+ sha256sums = 85c7578ce4b2d9c2454cfa4b5b3b5617829d1a77f579e7d33b34bd31542a8b32
pkgname = mingw-w64-syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index f53b82e45737..659d7eefe39e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,15 @@
# you also find the URL of a binary repository.
# set the web view provider: either webkit, webengine, auto or none
-_webview_provider=none
+_webview_provider=${SYNCTHING_TRAY_WEBVIEW_PROVIDER:-none}
+
+# set the JavaScript provider: either script, qml, auto or none
+_js_provider=${SYNCTHING_TRAY_JS_PROVIDER:-qml}
_reponame=syncthingtray
pkgname=mingw-w64-syncthingtray
_name=${pkgname#mingw-w64-}
-pkgver=0.8.2
+pkgver=0.8.3
pkgrel=1
arch=('any')
pkgdesc='Tray application for Syncthing (mingw-w64)'
@@ -21,7 +24,7 @@ depends=('mingw-w64-crt' 'mingw-w64-qt5-svg' 'mingw-w64-qtutilities' 'mingw-w64-
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('34ebc32c78bfc2c6ebba390e78dafc32e6eddbac7e613ab3b4573f79cb1c01b2')
+sha256sums=('85c7578ce4b2d9c2454cfa4b5b3b5617829d1a77f579e7d33b34bd31542a8b32')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -33,6 +36,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr/${_arch}" \
-DWEBVIEW_PROVIDER="${_webview_provider}" \
+ -DJS_PROVIDER="${_js_provider}" \
-DSYSTEMD_SUPPORT=OFF \
-DNO_FILE_ITEM_ACTION_PLUGIN=ON \
-DENABLE_STATIC_LIBS:BOOL=OFF \