summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2019-10-02 21:48:27 +0200
committerMartchus2019-10-02 21:48:27 +0200
commitdb6cf5155410786250f7bb9998de48a6e3ab5883 (patch)
treed8031c15cde6595835a11d39ec57db729e5fe146
parent6116fa6e62d7e59c253c2e8f708c33625cad2a30 (diff)
downloadaur-db6cf5155410786250f7bb9998de48a6e3ab5883.tar.gz
Update version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0bbeb3a5630..2bf40a17d91f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-syncthingtray
pkgdesc = Tray application for Syncthing (mingw-w64)
- pkgver = 0.10.0
+ pkgver = 0.10.1
pkgrel = 1
url = https://github.com/Martchus/syncthingtray
arch = any
@@ -25,9 +25,9 @@ pkgbase = mingw-w64-syncthingtray
options = staticlibs
options = !strip
options = !emptydirs
- source = syncthingtray-0.10.0.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.10.0.tar.gz
- source = syncthing::git+https://github.com/Martchus/syncthing.git#branch=libsyncthing3
- sha256sums = 89a87dc6eb38fcb75f22cb696257300603bdfda460732db4deb545dab19d6942
+ source = syncthingtray-0.10.1.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.10.1.tar.gz
+ source = syncthing::git+https://github.com/Martchus/syncthing.git#branch=libsyncthing-latest
+ sha256sums = 7b9674479a6c4a144f7ed4e00b8e39e96671702a89ed9a1c74555a687ff37b7d
sha256sums = SKIP
pkgname = mingw-w64-syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index 7cb438219697..5c469f71d7ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _enable_libsyncthing=${MINGW_W64_SYNCTHING_TRAY_JS_PROVIDER:-ON}
_reponame=syncthingtray
pkgname=mingw-w64-syncthingtray
_name=${pkgname#mingw-w64-}
-pkgver=0.10.0
+pkgver=0.10.1
pkgrel=1
arch=('any')
pkgdesc='Tray application for Syncthing (mingw-w64)'
@@ -30,8 +30,8 @@ makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
[[ $_enable_libsyncthing == ON ]] && makedepends+=('git' 'go')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-[[ $_enable_libsyncthing == ON ]] && source+=("syncthing::git+https://github.com/Martchus/syncthing.git#branch=libsyncthing3")
-sha256sums=('89a87dc6eb38fcb75f22cb696257300603bdfda460732db4deb545dab19d6942'
+[[ $_enable_libsyncthing == ON ]] && source+=("syncthing::git+https://github.com/Martchus/syncthing.git#branch=libsyncthing-latest")
+sha256sums=('7b9674479a6c4a144f7ed4e00b8e39e96671702a89ed9a1c74555a687ff37b7d'
'SKIP')
options=(!buildflags staticlibs !strip !emptydirs)
@@ -44,10 +44,16 @@ _configurations=()
prepare() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ # ensure path where the libsyncthing Git submodule would be cloned into exists
mkdir -p 'libsyncthing/go/src/github.com/syncthing'
pushd 'libsyncthing/go/src/github.com/syncthing'
- #[[ -d syncthing ]] && rm -r syncthing
+
+ # delete empty sub directory of the Git submodule present in the archive from GitHub
+ [[ -d syncthing ]] && rm -r syncthing
+
+ # link libsyncthing repo where the Git submodule would have been cloned into
ln -sf "$srcdir/syncthing" .
+
popd
}