summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-07-28 09:38:20 +0200
committerMichel Zou2019-07-28 09:38:20 +0200
commit46c7ae39808ddc2ae02d33ba89dd9fab3eac178b (patch)
tree77c32fae8675bea99510139100911f0a423712c5
downloadaur-46c7ae39808ddc2ae02d33ba89dd9fab3eac178b.tar.gz
2.1.5.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6d4a9461427
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-sz
+ pkgdesc = Error-bounded Lossy Data Compressor (for floating-point/integer datasets) (mingw-w64)
+ pkgver = 2.1.5.1
+ pkgrel = 1
+ url = https://collab.cels.anl.gov/display/ESR/SZ
+ arch = any
+ license = custom
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-zstd
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = https://github.com/disheng222/SZ/archive/v2.1.5.1.tar.gz
+ sha256sums = 5234df442714f3400ed5676d2dd151386f6763471e52f784c640f840b8ce40d5
+
+pkgname = mingw-w64-sz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4689059ab5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=mingw-w64-sz
+pkgver=2.1.5.1
+pkgrel=1
+pkgdesc="Error-bounded Lossy Data Compressor (for floating-point/integer datasets) (mingw-w64)"
+url="https://collab.cels.anl.gov/display/ESR/SZ"
+license=('custom')
+arch=('any')
+depends=('mingw-w64-zstd')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("https://github.com/disheng222/SZ/archive/v${pkgver}.tar.gz")
+sha256sums=('5234df442714f3400ed5676d2dd151386f6763471e52f784c640f840b8ce40d5')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "$srcdir/SZ-${pkgver}"
+ sed -i "s|ARCHIVE DESTINATION lib|ARCHIVE DESTINATION lib RUNTIME DESTINATION bin|g" sz/CMakeLists.txt
+}
+
+build() {
+ cd "$srcdir/SZ-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/SZ-${pkgver}/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}