summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-09-05 18:07:47 +0200
committerMartchus2023-09-05 18:07:47 +0200
commit3e7c264be44d22d204f137bc4b5063f4724dc0d6 (patch)
tree3d37c295e4592401dcdaa6c0067978ece70d9b47
parentb117c35913081e0dd05e2b6f3bed6d18712f8e1e (diff)
downloadaur-mingw-w64-tageditor.tar.gz
Update version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebe38b275709..87c45281ee9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-tageditor
pkgdesc = A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska
- pkgver = 3.8.1
+ pkgver = 3.9.0
pkgrel = 1
url = https://github.com/Martchus/tageditor
arch = any
@@ -25,7 +25,7 @@ pkgbase = mingw-w64-tageditor
options = staticlibs
options = !strip
options = !emptydirs
- source = tageditor-3.8.1.tar.gz::https://github.com/Martchus/tageditor/archive/v3.8.1.tar.gz
- sha256sums = 92965ed67676e46196d3178c99deb043d0af36c78f3756d72837de9fdfa10937
+ source = tageditor-3.9.0.tar.gz::https://github.com/Martchus/tageditor/archive/v3.9.0.tar.gz
+ sha256sums = ebafac24ab7c3833a018b5848b32d9fa2cfa01cafeff1b1ec1a6e30eb7415b1b
pkgname = mingw-w64-tageditor
diff --git a/PKGBUILD b/PKGBUILD
index 9ec1645281d4..b8d1507c9a6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _json_export=${MINGW_64_TAGEDITOR_JSON_EXPORT:-ON}
_reponame=tageditor
pkgname=mingw-w64-tageditor
_name=${pkgname#mingw-w64-}
-pkgver=3.8.1
+pkgver=3.9.0
pkgrel=1
arch=('any')
pkgdesc='A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska'
@@ -30,7 +30,7 @@ makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg' 'n
[[ $_json_export == ON ]] && makedepends+=('mingw-w64-reflective-rapidjson')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('92965ed67676e46196d3178c99deb043d0af36c78f3756d72837de9fdfa10937')
+sha256sums=('ebafac24ab7c3833a018b5848b32d9fa2cfa01cafeff1b1ec1a6e30eb7415b1b')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
@@ -97,6 +97,27 @@ build() {
done
}
+check() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+
+ if [[ -z $TEST_FILE_PATH ]]; then
+ msg2 'Skipping execution of testsuite because the environment variable TEST_FILE_PATH is not set.'
+ return
+ fi
+
+ # note: Only testing the most important configuration here because executing the tests takes quite a while.
+ for _arch in 'x86_64-w64-mingw32'; do
+ for _cfg in 'static'; do
+ msg2 "${_arch}-${_cfg}"
+ pushd "build-${_arch}-${_cfg}"
+ export WINEPATH="/usr/${_arch}/bin" WINEDEBUG=-all
+ export QT_QPA_PLATFORM=offscreen
+ [[ $_cfg == shared ]] && ninja check
+ popd
+ done
+ done
+}
+
package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"