summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2015-12-27 23:13:08 +0100
committerMartchus2015-12-27 23:13:08 +0100
commit2c36177c3c79b44dd493a1b7222d60a4eb9467fe (patch)
treee456181beaae2dc25db580a50cdc0390e13b540c
downloadaur-2c36177c3c79b44dd493a1b7222d60a4eb9467fe.tar.gz
initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD36
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f2c9ae78e85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 22:13:08 UTC 2015
+pkgbase = mingw-w64-tageditor
+ pkgdesc = A tageditor with Qt GUI and command line interface supporting MP4 (iTunes), ID3, Vorbis and Matroska (mingw-w64).
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/Martchus/tageditor
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-qt5-tools
+ makedepends = ffmpeg
+ depends = mingw-w64-crt
+ depends = mingw-w64-qt5-script
+ depends = mingw-w64-qt5-webkit
+ depends = mingw-w64-qtutilities
+ depends = mingw-w64-tagparser
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ options = !emptydirs
+ source = tageditor-1.3.0.tar.gz::https://github.com/Martchus/tageditor/archive/v1.3.0.tar.gz
+ sha256sums = 6b050fe5281b0be7dba02783e86dfb93c781c8271be949e81371113905db1312
+
+pkgname = mingw-w64-tageditor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..155b4f8022f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Martchus <martchus@gmx.net>
+_name=tageditor
+_reponame=tageditor
+pkgname=mingw-w64-tageditor
+pkgver=1.3.0
+pkgrel=1
+arch=('any')
+pkgdesc="A tageditor with Qt GUI and command line interface supporting MP4 (iTunes), ID3, Vorbis and Matroska (mingw-w64)."
+license=('GPL')
+depends=(mingw-w64-{crt,qt5-script,qt5-webkit,qtutilities,tagparser})
+makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
+url="https://github.com/Martchus/${_reponame}"
+source=("tageditor-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
+sha256sums=('6b050fe5281b0be7dba02783e86dfb93c781c8271be949e81371113905db1312')
+options=(!buildflags staticlibs !strip !emptydirs)
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ # build utilities for each architecture
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr/${_arch}" ../
+ make
+ popd
+ done
+}
+
+package() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+ make install-mingw-w64-strip
+ popd
+ done
+}