summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-19 13:17:44 +0100
committerMartchus2020-01-19 13:17:44 +0100
commit5506ce63001ce9d7bd7a90b85a02e625213bd172 (patch)
tree167fe79fe77202da1e1ef3363f945ccc2f3541a4
parentfa8eea86ed744594db55d99014925cf9ec37473f (diff)
downloadaur-5506ce63001ce9d7bd7a90b85a02e625213bd172.tar.gz
Update version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20e1c64d9469..478834660bf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-tageditor
pkgdesc = A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska
- pkgver = 3.3.2
+ pkgver = 3.3.3
pkgrel = 1
url = https://github.com/Martchus/tageditor
arch = any
@@ -23,8 +23,8 @@ pkgbase = mingw-w64-tageditor
options = staticlibs
options = !strip
options = !emptydirs
- source = tageditor-3.3.2.tar.gz::https://github.com/Martchus/tageditor/archive/v3.3.2.tar.gz
- sha256sums = 6cf8bd296b8a38260cb0583395890fd64910f62a9b365354b1bc2526a86bbec9
+ source = tageditor-3.3.3.tar.gz::https://github.com/Martchus/tageditor/archive/v3.3.3.tar.gz
+ sha256sums = b32ea1c3c2af626b8207f927d89db1e861d5efcf0a45f84fe21e020a841c4c54
pkgname = mingw-w64-tageditor
diff --git a/PKGBUILD b/PKGBUILD
index 43e773b3eea5..374fd52946da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _json_export=${MINGW_64_TAGEDITOR_JSON_EXPORT:-ON}
_reponame=tageditor
pkgname=mingw-w64-tageditor
_name=${pkgname#mingw-w64-}
-pkgver=3.3.2
+pkgver=3.3.3
pkgrel=1
arch=('any')
pkgdesc='A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska'
@@ -30,7 +30,7 @@ makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
[[ $_json_export == ON ]] && makedepends+=('mingw-w64-reflective-rapidjson')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('6cf8bd296b8a38260cb0583395890fd64910f62a9b365354b1bc2526a86bbec9')
+sha256sums=('b32ea1c3c2af626b8207f927d89db1e861d5efcf0a45f84fe21e020a841c4c54')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
@@ -91,6 +91,10 @@ build() {
package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ install \
+ -D --target-directory="$pkgdir/usr/share/licenses/$pkgname" \
+ LICENSES-windows-distribution.md
+
for _arch in "${_architectures[@]}"; do
for _cfg in "${_configurations[@]}"; do
msg2 "${_arch}-${_cfg}"