summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-06-19 15:44:34 +0200
committerMartchus2016-06-19 15:44:34 +0200
commitdd893a458c0afded58d25093ff4976ba3659cd06 (patch)
tree6b3ea516f864f6302a40906777f582c63a1efa8c
parent2c36177c3c79b44dd493a1b7222d60a4eb9467fe (diff)
downloadaur-dd893a458c0afded58d25093ff4976ba3659cd06.tar.gz
Update to 1.4.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 32 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f2c9ae78e85..61a96ce01d02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 27 22:13:08 UTC 2015
+# Sun Jun 19 13:44:32 UTC 2016
pkgbase = mingw-w64-tageditor
- pkgdesc = A tageditor with Qt GUI and command line interface supporting MP4 (iTunes), ID3, Vorbis and Matroska (mingw-w64).
- pkgver = 1.3.0
+ pkgdesc = A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus and Matroska (mingw-w64).
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/Martchus/tageditor
arch = any
@@ -12,16 +12,15 @@ pkgbase = mingw-w64-tageditor
makedepends = mingw-w64-qt5-tools
makedepends = ffmpeg
depends = mingw-w64-crt
- depends = mingw-w64-qt5-script
- depends = mingw-w64-qt5-webkit
depends = mingw-w64-qtutilities
depends = mingw-w64-tagparser
+ depends = mingw-w64-qt5-script
options = !buildflags
options = staticlibs
options = !strip
options = !emptydirs
- source = tageditor-1.3.0.tar.gz::https://github.com/Martchus/tageditor/archive/v1.3.0.tar.gz
- sha256sums = 6b050fe5281b0be7dba02783e86dfb93c781c8271be949e81371113905db1312
+ source = tageditor-1.4.0.tar.gz::https://github.com/Martchus/tageditor/archive/v1.4.0.tar.gz
+ sha256sums = 37281b85c633b2f91310c0747f6ae69a108961ee5de1fa5ad3ba27a1707359aa
pkgname = mingw-w64-tageditor
diff --git a/PKGBUILD b/PKGBUILD
index 155b4f8022f3..dccafbabc82f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,32 @@
# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+# set the web view provider: either webkit, webengine or none
+_webview_provider=none
+
+# set the JavaScript provider: either script, qml or none
+_js_provider=script
+
_name=tageditor
_reponame=tageditor
pkgname=mingw-w64-tageditor
-pkgver=1.3.0
+pkgver=1.4.0
pkgrel=1
arch=('any')
-pkgdesc="A tageditor with Qt GUI and command line interface supporting MP4 (iTunes), ID3, Vorbis and Matroska (mingw-w64)."
+pkgdesc="A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus and Matroska (mingw-w64)."
license=('GPL')
-depends=(mingw-w64-{crt,qt5-script,qt5-webkit,qtutilities,tagparser})
+depends=(mingw-w64-{crt,qtutilities,tagparser})
+[[ $_webview_provider == none ]] && [[ $_js_provider == none ]] && depends+=('mingw-w64-qt5-base')
+[[ $_webview_provider == webkit ]] && depends+=('mingw-w64-qt5-webkit')
+[[ $_webview_provider == webengine ]] && depends+=('mingw-w64-qt5-webengine')
+[[ $_js_provider == script ]] && depends+=('mingw-w64-qt5-script')
+[[ $_js_provider == qml ]] && depends+=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
url="https://github.com/Martchus/${_reponame}"
source=("tageditor-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('6b050fe5281b0be7dba02783e86dfb93c781c8271be949e81371113905db1312')
+sha256sums=('37281b85c633b2f91310c0747f6ae69a108961ee5de1fa5ad3ba27a1707359aa')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -20,7 +35,12 @@ build() {
# build utilities for each architecture
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr/${_arch}" ../
+ ${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr/${_arch}" \
+ -DWEBVIEW_PROVIDER="${_webview_provider}" \
+ -DJS_PROVIDER="${_js_provider}" \
+ ../
make
popd
done
@@ -30,7 +50,7 @@ package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
for _arch in ${_architectures}; do
pushd build-${_arch}
- make install-mingw-w64-strip
+ make DESTDIR="${pkgdir}" install-mingw-w64-strip
popd
done
}