summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 23:49:01 +0200
committerxantares2015-06-08 23:49:01 +0200
commit424a3a4f6820f43fbf95088cdb02069fcf6c10a5 (patch)
treedc8a32aba9b1d2d0fe25538d29faaf7b8b02ffea
downloadaur-424a3a4f6820f43fbf95088cdb02069fcf6c10a5.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77bbeffff37d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-tinyxml2
+ pkgdesc = Simple, small, C++ XML parser that can be easily integrated into other programs (mingw-w64)
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = https://github.com/leethomason/tinyxml2
+ arch = any
+ license = zlib
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = https://github.com/leethomason/tinyxml2/archive/2.2.0.tar.gz
+ md5sums = 3c7a9191c8f26e4f056a89902ac848b1
+
+pkgname = mingw-w64-tinyxml2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afc08c57b2db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+
+pkgname=mingw-w64-tinyxml2
+pkgver=2.2.0
+pkgrel=1
+pkgdesc='Simple, small, C++ XML parser that can be easily integrated into other programs (mingw-w64)'
+url="https://github.com/leethomason/tinyxml2"
+arch=('any')
+license=('zlib')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-cmake')
+options=('staticlibs' '!strip' '!buildflags')
+source=("${url}/archive/${pkgver}.tar.gz")
+md5sums=('3c7a9191c8f26e4f056a89902ac848b1')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/tinyxml2-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/tinyxml2-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}