summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxlwz2021-08-26 21:52:19 +0800
committerxlwz2021-08-26 21:52:19 +0800
commit31fbf8c46632eb9c849a75c1088b05619a2ec01b (patch)
tree4d21cd8576d56c0519526f0247356f88efe78071
parent146ae7c784ceea40fa9f372cfc75024cfc4fe262 (diff)
downloadaur-31fbf8c46632eb9c849a75c1088b05619a2ec01b.tar.gz
update to 8.6.11
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD66
-rw-r--r--tk-implib-name.patch40
4 files changed, 44 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8b2e38f41d8..81040508d3d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-tk
pkgdesc = A windowing toolkit for use with tcl (mingw-w64)
- pkgver = 8.6.9.1
+ pkgver = 8.6.11.1
pkgrel = 1
url = http://tcl.sourceforge.io
arch = any
@@ -12,18 +12,15 @@ pkgbase = mingw-w64-tk
options = staticlibs
options = !strip
options = !buildflags
- source = http://downloads.sourceforge.net/sourceforge/tcl/tk8.6.9.1-src.tar.gz
+ source = http://downloads.sourceforge.net/sourceforge/tcl/tk8.6.11.1-src.tar.gz
source = tk-prevent-tclStubsPtr-segfault.patch
source = tk-install-man.patch
- source = tk-implib-name.patch
source = tk-fix-forbidden-colon-in-paths.patch
source = tk-dont-link-shared-with-static-libgcc.patch
- sha256sums = 8fcbcd958a8fd727e279f4cac00971eee2ce271dc741650b1fc33375fb74ebb4
+ sha256sums = 006cab171beeca6a968b6d617588538176f27be232a2b334a0e96173e89909be
sha256sums = 0029fde6782ce7635e9957412d3e36a7e76d304399d57d64a42818f93e705621
sha256sums = 8516749dd73c084ece7b9df6d1ba5708e652e8ba39cad59120c7f909f61747f0
- sha256sums = 441f2f5bdf1ee2bf6697569365207d554130bd5a2bac01e10a6e1a37738d8006
sha256sums = 5347487af0e736dbb51425b22ed308840faf75b44c070623baa55f78dac3d053
sha256sums = a16406e8519ab681bba0915e35b23a7f91cf978934b0a4ebdc7e949e87f0c877
pkgname = mingw-w64-tk
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f4266263d502
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/pkg
+
+/src
+
+*.gz
+
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index 6b6634035b4e..5194617585c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
+# Maintainer: xlwz <xlwzforever@outlook.com>
+
pkgname=mingw-w64-tk
-_basever=8.6.9
+_basever=8.6.11
_patch=.1
pkgver=${_basever}${_patch}
pkgrel=1
@@ -13,13 +15,11 @@ url="http://tcl.sourceforge.io"
source=("http://downloads.sourceforge.net/sourceforge/tcl/tk${pkgver}-src.tar.gz"
"tk-prevent-tclStubsPtr-segfault.patch"
"tk-install-man.patch"
- "tk-implib-name.patch"
"tk-fix-forbidden-colon-in-paths.patch"
"tk-dont-link-shared-with-static-libgcc.patch")
-sha256sums=('8fcbcd958a8fd727e279f4cac00971eee2ce271dc741650b1fc33375fb74ebb4'
+sha256sums=('006cab171beeca6a968b6d617588538176f27be232a2b334a0e96173e89909be'
'0029fde6782ce7635e9957412d3e36a7e76d304399d57d64a42818f93e705621'
'8516749dd73c084ece7b9df6d1ba5708e652e8ba39cad59120c7f909f61747f0'
- '441f2f5bdf1ee2bf6697569365207d554130bd5a2bac01e10a6e1a37738d8006'
'5347487af0e736dbb51425b22ed308840faf75b44c070623baa55f78dac3d053'
'a16406e8519ab681bba0915e35b23a7f91cf978934b0a4ebdc7e949e87f0c877')
@@ -29,7 +29,6 @@ prepare() {
cd "${srcdir}/tk${_basever}"
patch -Np1 -i "${srcdir}/tk-prevent-tclStubsPtr-segfault.patch"
patch -Np1 -i "${srcdir}/tk-install-man.patch"
- patch -Np1 -i "${srcdir}/tk-implib-name.patch"
patch -Np1 -i "${srcdir}/tk-fix-forbidden-colon-in-paths.patch"
patch -Np1 -i "${srcdir}/tk-dont-link-shared-with-static-libgcc.patch"
cd win && autoreconf -fi
@@ -57,37 +56,40 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/tk${_basever}/win/build-${_arch}"
make -j1 install INSTALL_ROOT="$pkgdir"
- cp "${pkgdir}/usr/${_arch}/bin/wish86${debug_suffix}.exe" "${pkgdir}/usr/${_arch}/bin/wish.exe"
- find "${pkgdir}/usr/${_arch}" -name '*.def' -o -name '*.exp' | xargs -rtl1 rm
- find "${pkgdir}/usr/${_arch}" -name '*.sh' -o -name '*.dll' -o -name '*.exe' | xargs -rtl1 chmod 755
+ cp "${pkgdir}/usr/${_arch}/bin/wish86${debug_suffix}.exe" "${pkgdir}/usr/${_arch}/bin/wish.exe"
+ find "${pkgdir}/usr/${_arch}" -name '*.def' -o -name '*.exp' | xargs -rtl1 rm
+ find "${pkgdir}/usr/${_arch}" -name '*.sh' -o -name '*.dll' -o -name '*.exe' | xargs -rtl1 chmod 755
- ln -s "${pkgdir}/usr/${_arch}/lib/libtk86${debug_suffix}.dll.a" "${pkgdir}/usr/${_arch}/lib/libtk.dll.a"
- mkdir -p "${pkgdir}/usr/${_arch}/include/tk${_basever%.*}/tk-private/"{generic/ttk,win}
+ ln -s "${pkgdir}/usr/${_arch}/lib/libtk86${debug_suffix}.dll.a" "${pkgdir}/usr/${_arch}/lib/libtk.dll.a"
+ mkdir -p "${pkgdir}/usr/${_arch}/include/tk${_basever%.*}/tk-private/"{generic/ttk,win}
- cd ${srcdir}/tk${_basever}
- find generic win -name "*.h" -exec cp -p '{}' "${pkgdir}/usr/${_arch}"/include/tk${_basever%.*}/tk-private/'{}' ';'
- ( cd "${pkgdir}/usr/${_arch}/include"
- for header in *.h ; do
- cp -f ${header} ${pkgdir}/usr/${_arch}/include/tk${_basever%.*}/tk-private/generic/
- done
- )
- chmod a-x "${pkgdir}/usr/${_arch}/lib/"*/pkgIndex.tcl
+ cd ${srcdir}/tk${_basever}
+ find generic win -name "*.h" -exec cp -p '{}' "${pkgdir}/usr/${_arch}"/include/tk${_basever%.*}/tk-private/'{}' ';'
+ ( cd "${pkgdir}/usr/${_arch}/include"
+ for header in *.h ; do
+ cp -f ${header} ${pkgdir}/usr/${_arch}/include/tk${_basever%.*}/tk-private/generic/
+ done
+ )
+ chmod a-x "${pkgdir}/usr/${_arch}/lib/"*/pkgIndex.tcl
- local _libver=${_basever%.*}
- _libver=${_libver//./}
- sed -i \
- -e "s|^\(TK_BUILD_LIB_SPEC\)='.*|\1='-Wl,/usr/${_arch}/lib/libtk${_libver}.dll.a'|" \
- -e "s|^\(TK_SRC_DIR\)='.*'|\1='/usr/${_arch}/include/tk${_basever%.*}/tk-private'|" \
- -e "s|^\(TK_BUILD_STUB_LIB_SPEC\)='.*|\1='-Wl,/usr/${_arch}/lib/libtkstub${_libver}.a'|" \
- -e "s|^\(TK_BUILD_STUB_LIB_PATH\)='.*|\1='/usr/${_arch}/lib/libtkstub${_libver}.a'|" \
- -e "s|^\(TK_STUB_LIB_SPEC\)='.*|\1='-L/usr/${_arch}/lib -ltkstub${_libver}'|" \
- ${pkgdir}/usr/${_arch}/lib/tkConfig.sh
+ local _libver=${_basever%.*}
+ _libver=${_libver//./}
+ sed -i \
+ -e "s|^\(TK_BUILD_LIB_SPEC\)='.*|\1='-Wl,/usr/${_arch}/lib/libtk${_libver}.dll.a'|" \
+ -e "s|^\(TK_SRC_DIR\)='.*'|\1='/usr/${_arch}/include/tk${_basever%.*}/tk-private'|" \
+ -e "s|^\(TK_BUILD_STUB_LIB_SPEC\)='.*|\1='-Wl,/usr/${_arch}/lib/libtkstub${_libver}.a'|" \
+ -e "s|^\(TK_BUILD_STUB_LIB_PATH\)='.*|\1='/usr/${_arch}/lib/libtkstub${_libver}.a'|" \
+ -e "s|^\(TK_STUB_LIB_SPEC\)='.*|\1='-L/usr/${_arch}/lib -ltkstub${_libver}'|" \
+ ${pkgdir}/usr/${_arch}/lib/tkConfig.sh
- # Add missing entry to tkConfig.sh
- echo "# String to pass to the compiler so that an extension can" >> ${pkgdir}/usr/${_arch}/lib/tkConfig.sh
- echo "# find installed Tcl headers." >> ${pkgdir}/usr/${_arch}/lib/tkConfig.sh
- echo "TK_INCLUDE_SPEC='-I/usr/${_arch}/include/tk${_basever%.*}'" >> ${pkgdir}/usr/${_arch}/lib/tkConfig.sh
+ # Add missing entry to tkConfig.sh
+ echo "# String to pass to the compiler so that an extension can" >> ${pkgdir}/usr/${_arch}/lib/tkConfig.sh
+ echo "# find installed Tcl headers." >> ${pkgdir}/usr/${_arch}/lib/tkConfig.sh
+ echo "TK_INCLUDE_SPEC='-I/usr/${_arch}/include/tk${_basever%.*}'" >> ${pkgdir}/usr/${_arch}/lib/tkConfig.sh
- rm "${pkgdir}/usr/${_arch}/lib/tk${_basever%.*}/tkAppInit.c"
+ rm "${pkgdir}/usr/${_arch}/lib/tk${_basever%.*}/tkAppInit.c"
done
+
+ cd ${srcdir}/tk${_basever}
+ install -Dm644 license.terms "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/tk-implib-name.patch b/tk-implib-name.patch
deleted file mode 100644
index de42c877c4db..000000000000
--- a/tk-implib-name.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -Naur tk8.6.5-orig/win/configure.in tk8.6.5/win/configure.in
---- tk8.6.5-orig/win/configure.in 2016-02-29 22:13:21.000000000 +0300
-+++ tk8.6.5/win/configure.in 2016-03-03 09:21:51.294037200 +0300
-@@ -166,7 +166,11 @@
- eval "TK_SRC_DIR=\"`cd $srcdir/..; pwd`\""
-
- eval "TK_DLL_FILE=tk$VER${DLLSUFFIX}"
--eval "TK_LIB_FILE=${LIBPREFIX}tk$VER${LIBSUFFIX}"
-+if test ${SHARED_BUILD} = 0 ; then
-+ eval "TK_LIB_FILE=${LIBPREFIX}tk$VER${LIBSUFFIX}"
-+else
-+ eval "TK_LIB_FILE=${LIBPREFIX}tk$VER${DLLSUFFIX}.a"
-+fi
-
- eval "TK_STUB_LIB_FILE=${LIBPREFIX}tkstub${VER}${LIBSUFFIX}"
- # FIXME: All of this var junk needs to be done in tcl.m4 !!!!
-diff -Naur tk8.6.5-orig/win/Makefile.in tk8.6.5/win/Makefile.in
---- tk8.6.5-orig/win/Makefile.in 2016-02-29 22:13:21.000000000 +0300
-+++ tk8.6.5/win/Makefile.in 2016-03-03 09:21:51.324037200 +0300
-@@ -135,7 +135,7 @@
- TK_LIB_FILE = @TK_LIB_FILE@
- TK_DLL_FILE = @TK_DLL_FILE@
- TEST_DLL_FILE = tktest$(VER)${DLLSUFFIX}
--TEST_LIB_FILE = @LIBPREFIX@tktest$(VER)${LIBSUFFIX}
-+TEST_LIB_FILE = @LIBPREFIX@tktest$(VER)${DLLSUFFIX}${LIBSUFFIX}
-
- SHARED_LIBRARIES = $(TK_DLL_FILE) $(TK_STUB_LIB_FILE)
- STATIC_LIBRARIES = $(TK_LIB_FILE)
-diff -Naur tk8.6.5-orig/win/tcl.m4 tk8.6.5/win/tcl.m4
---- tk8.6.5-orig/win/tcl.m4 2016-02-29 22:13:21.000000000 +0300
-+++ tk8.6.5/win/tcl.m4 2016-03-03 09:21:51.337037200 +0300
-@@ -715,7 +715,7 @@
- SHLIB_LD='${CC} -shared'
- SHLIB_LD_LIBS='${LIBS}'
- MAKE_DLL="\${SHLIB_LD} \$(LDFLAGS) -o \[$]@ ${extra_ldflags} \
-- -Wl,--out-implib,\$(patsubst %.dll,lib%.a,\[$]@)"
-+ -Wl,--out-implib,\$(patsubst %.dll,lib%.dll.a,\[$]@)"
- # DLLSUFFIX is separate because it is the building block for
- # users of tclConfig.sh that may build shared or static.
- DLLSUFFIX="\${DBGX}.dll"