summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-06-01 08:29:32 +0200
committerMichel Zou2018-06-01 08:29:32 +0200
commit754e769376dd9bb01437d1bf48b8548315f9e547 (patch)
treec65ca8f132431c6eefe812352b75a515b997a6c7
parent40edc566403a4a75b0163a386ebe75ffb8cb07ab (diff)
downloadaur-754e769376dd9bb01437d1bf48b8548315f9e547.tar.gz
5.0.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--patch.txt41
3 files changed, 9 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f5549621569..359b89fb5996 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jun 7 03:02:10 UTC 2017
+# Fri Jun 1 06:29:32 UTC 2018
pkgbase = mingw-w64-tools
pkgdesc = MinGW-w64 utilities
- pkgver = 5.0.2
- pkgrel = 2
+ pkgver = 5.0.3
+ pkgrel = 1
url = http://mingw-w64.sourceforge.net
arch = i686
arch = x86_64
@@ -12,10 +12,8 @@ pkgbase = mingw-w64-tools
license = LGPL2
options = !libtool
options = !emptydirs
- source = http://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/mingw-w64-v5.0.2.tar.bz2
- source = patch.txt
- md5sums = 80d6884c9da234e73054347f44158b8a
- md5sums = 9f5edb073b656a82c5672680935d1e51
+ source = http://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/mingw-w64-v5.0.3.tar.bz2
+ sha256sums = 2a601db99ef579b9be69c775218ad956a24a09d7dabc9ff6c5bd60da9ccc9cb4
pkgname = mingw-w64-tools
diff --git a/PKGBUILD b/PKGBUILD
index 414cda9273cb..4a9b473f809f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,18 @@
pkgname=mingw-w64-tools
-pkgver=5.0.2
+pkgver=5.0.3
_pkgver=${pkgver/rc/-rc}
-pkgrel=2
+pkgrel=1
pkgdesc="MinGW-w64 utilities"
arch=(i686 x86_64)
url="http://mingw-w64.sourceforge.net"
license=("GPL3" "LGPL2")
groups=(mingw-w64)
options=(!libtool !emptydirs)
-source=("http://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/mingw-w64-v${_pkgver}.tar.bz2"
-"patch.txt")
-md5sums=('80d6884c9da234e73054347f44158b8a'
- '9f5edb073b656a82c5672680935d1e51')
+source=("http://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/mingw-w64-v${_pkgver}.tar.bz2")
+sha256sums=('2a601db99ef579b9be69c775218ad956a24a09d7dabc9ff6c5bd60da9ccc9cb4')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "${srcdir}"/mingw-w64-v${_pkgver}
- patch -p1 -i "${srcdir}"/patch.txt
-}
-
build() {
cd "${srcdir}"
mkdir -p "${srcdir}"/gendef-build && cd "${srcdir}"/gendef-build
diff --git a/patch.txt b/patch.txt
deleted file mode 100644
index 859e00243d33..000000000000
--- a/patch.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git a/mingw-w64-tools/gendef/src/gendef.c b/mingw-w64-tools/gendef/src/gendef.c
-index a935abfe..cefdd8cb 100644
---- a/mingw-w64-tools/gendef/src/gendef.c
-+++ b/mingw-w64-tools/gendef/src/gendef.c
-@@ -1031,13 +1031,16 @@ redo_switch:
- PRDEBUG(" 0x%x illegal ", (unsigned int) b);
- #endif
- *aCode=c_ill; return 0;
-- case c_4: sz++;
-- case c_3: sz++;
-- case c_lb:
-- case c_2: sz++;
-- case c_retn: case c_retf:
-- case c_iret: case c_int3:
-- case c_ad: case c_op:
-+ case c_4: sz++; // fallthrough
-+ case c_3: sz++; // fallthrough
-+ case c_lb: // fallthrough
-+ case c_2: sz++; // fallthrough
-+ case c_retn: // fallthrough
-+ case c_retf: // fallthrough
-+ case c_iret: // fallthrough
-+ case c_int3: // fallthrough
-+ case c_ad: // fallthrough
-+ case c_op: // fallthrough
- case c_1: *aCode=tb1; return sz;
- case c_lv:
- if (oper_mode) sz+=4;
-diff --git a/mingw-w64-tools/genpeimg/src/genpeimg.c b/mingw-w64-tools/genpeimg/src/genpeimg.c
-index b2430bbc..6a37b1a0 100644
---- a/mingw-w64-tools/genpeimg/src/genpeimg.c
-+++ b/mingw-w64-tools/genpeimg/src/genpeimg.c
-@@ -203,7 +203,7 @@ pass_args (int argc, char **argv)
- goto error_point;
- case 'h':
- if (h[2] == 0)
-- show_usage ();
-+ show_usage (); // fallthrough
- default:
- error_point:
- fprintf (stderr, "Unknown option ,%s'\n", h);