summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-07-29 21:50:32 -0400
committerAndrew Sun2018-07-29 21:50:32 -0400
commit3fab909634f5f911476e35e2f6b0e4c42047eb12 (patch)
tree1cbd843258a000364c026a7a6ed6a7dd046bba7e
downloadaur-3fab909634f5f911476e35e2f6b0e4c42047eb12.tar.gz
add mingw-w64-tslib (version 1.16)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54edb45d42cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-tslib
+ pkgdesc = Touchscreen Access Library (mingw-w64)
+ pkgver = 1.16
+ pkgrel = 1
+ url = https://github.com/kergoth/tslib
+ arch = any
+ license = GPL2
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/kergoth/tslib/releases/download/1.16/tslib-1.16.tar.xz
+ sha256sums = c9a54651337a701a66b074c603c313225579995a7910e519bbc7b1dcdab9a755
+
+pkgname = mingw-w64-tslib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50339d8949ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
+pkgname=mingw-w64-tslib
+_pkgname=tslib
+pkgver=1.16
+pkgrel=1
+pkgdesc="Touchscreen Access Library (mingw-w64)"
+arch=('any')
+url="https://github.com/kergoth/tslib"
+license=('GPL2')
+makedepends=('mingw-w64-configure')
+depends=('mingw-w64-crt')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("https://github.com/kergoth/tslib/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.xz")
+sha256sums=('c9a54651337a701a66b074c603c313225579995a7910e519bbc7b1dcdab9a755')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure \
+ --sysconfdir=/usr/${_arch}/etc \
+ --disable-input \
+ --disable-touchkit \
+ --disable-waveshare \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${_pkgname}-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/lib/ts/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/ts/*.a
+ done
+}