summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Nicholi2020-10-15 06:31:25 -0400
committerAlexander Nicholi2020-10-15 06:31:25 -0400
commit1e2cb10e10c640481e1f1ee5946cbb97397e4eb6 (patch)
tree4e241a01f2c3b44fca592ab4b8d67c83b790dd67
downloadaur-1e2cb10e10c640481e1f1ee5946cbb97397e4eb6.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a517c4ee18f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-unilib
+ pkgdesc = unilib, the ANSI C support library (MinGW-W64)
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/aquefir/{mingw-w64-unilib#mingw-w64-}
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-crt
+ provides = mingw-w64-unilib
+ conflicts = mingw-w64-unilib
+ options = !libtool
+ options = !buildflags
+ source = https://github.com/aquefir/unilib/archive/v1.1.0-1.2.1.tar.gz
+ sha1sums = 2f95b63cd63161bcfb11bd5e238978ad4ff02c09
+
+pkgname = mingw-w64-unilib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50bc49714228
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Alexander Nicholi <me@nicholatian.com>
+
+pkgname=mingw-w64-unilib
+pkgver=1.2.1
+pkgrel=1
+pkgdesc='unilib, the ANSI C support library (MinGW-W64)'
+arch=('any')
+url="https://github.com/aquefir/{$pkgname#mingw-w64-}"
+license=('BSD')
+makedepends=(mingw-w64-gcc)
+depends=(mingw-w64-crt)
+options=(!libtool !buildflags)
+provides=("$pkgname")
+conflicts=("$pkgname")
+_symver=1.1.0
+source=("https://github.com/aquefir/${pkgname#mingw-w64-}/releases/download/v$pkgver/${pkgname#mingw-w64-}-$pkgver.tar.bz2")
+source=("https://github.com/aquefir/${pkgname#mingw-w64-}/archive/v${_symver}-$pkgver.tar.gz")
+sha1sums=('2f95b63cd63161bcfb11bd5e238978ad4ff02c09')
+
+_subprojects='arr chkmath decl endian err himem log str'
+
+build() {
+ cd "$srcdir/${pkgname#mingw-w64-}-${_symver}-$pkgver"
+
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ make -j$(($(nproc) * 2)) release TP=Win64
+ cd ..
+ done
+}
+
+package() {
+ cd "$srcdir/${pkgname#mingw-w64-}-${_symver}-$pkgver"
+
+ cd log
+ make -i install PREFIX="${pkgdir}/usr/agb-armv4t-eabi" TP=Win64
+ cd ..
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ make install PREFIX="${pkgdir}/usr/agb-armv4t-eabi" TP=Win64
+ cd ..
+ done
+}