summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2018-04-04 01:33:18 -0400
committerSean Anderson2018-04-04 01:33:18 -0400
commit6a87629878009690c55a01489db961bc4e637a28 (patch)
tree04b2f767763d8d0a4756d1ce67c5a1703944279c
downloadaur-6a87629878009690c55a01489db961bc4e637a28.tar.gz
Initial Commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf09369ea580
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mingw-w64-unixodbc
+ pkgdesc = ODBC is an open specification for providing application developers with a predictable API with which to access Data Sources (mingw-w64)
+ pkgver = 2.3.6
+ pkgrel = 1
+ url = http://www.unixodbc.org/
+ arch = any
+ license = GPL2
+ license = LGPL2.1
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-readline
+ depends = mingw-w64-libtool
+ backup = usr/i686-w64-mingw32/etc/odbc.ini
+ backup = usr/i686-w64-mingw32/etc/odbcinst.ini
+ backup = usr/x86_64-w64-mingw32/etc/odbc.ini
+ backup = usr/x86_64-w64-mingw32/etc/odbcinst.ini
+ source = ftp://ftp.unixodbc.org/pub/unixODBC/unixODBC-2.3.6.tar.gz
+ md5sums = a8629fd2953b04b4639d0a9d8a5cf9d1
+
+pkgname = mingw-w64-unixodbc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74b1590d3013
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# $Id$
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=mingw-w64-unixodbc
+pkgver=2.3.6
+pkgrel=1
+pkgdesc="ODBC is an open specification for providing application developers with a predictable API with which to access Data Sources (mingw-w64)"
+arch=('any')
+license=('GPL2' 'LGPL2.1')
+url="http://www.unixodbc.org/"
+backup=('usr/i686-w64-mingw32/etc/odbc.ini' 'usr/i686-w64-mingw32/etc/odbcinst.ini'
+ 'usr/x86_64-w64-mingw32/etc/odbc.ini' 'usr/x86_64-w64-mingw32/etc/odbcinst.ini')
+depends=('mingw-w64-readline' 'mingw-w64-libtool')
+makedepends=('mingw-w64-configure')
+source=(ftp://ftp.unixodbc.org/pub/unixODBC/unixODBC-$pkgver.tar.gz)
+md5sums=('a8629fd2953b04b4639d0a9d8a5cf9d1')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd unixODBC-${pkgver}
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure ..
+ make
+ popd
+ done
+}
+
+check() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/unixODBC-$pkgver/build-${_arch}"
+ make -k check
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/unixODBC-$pkgver/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ touch "$pkgdir"/usr/${_arch}/etc/{odbc,odbcinst}.ini
+
+ rm "$pkgdir"/usr/${_arch}/include/{odbcinst,sql,sqlext,sqltypes,sqlucode}.h
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}