summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2017-01-15 00:47:42 +0100
committerkfg2017-04-14 10:39:14 +0200
commit2014bb44449d94f3f9b9a31c5619785adaf3f068 (patch)
treee84487887bdff9073a340b1a934e0f1abcb9eddf
parent8ab55dc1f708124b73ce4d45e25030f582767e12 (diff)
downloadaur-2014bb44449d94f3f9b9a31c5619785adaf3f068.tar.gz
upgpkg: mingw-w64-unshield 1.4.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
-rw-r--r--seperate_build_dir.patch21
3 files changed, 20 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9ad83536cf8..39290fb66073 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Apr 14 08:38:40 UTC 2017
pkgbase = mingw-w64-unshield
pkgdesc = Extracts CAB files from InstallShield installers (mingw-w64)
- pkgver = 1.3
+ pkgver = 1.4.1
pkgrel = 1
url = https://github.com/twogood/unshield
arch = any
@@ -14,10 +16,8 @@ pkgbase = mingw-w64-unshield
options = !strip
options = !libtool
options = staticlibs
- source = unshield-1.3.tar.gz::https://github.com/twogood/unshield/archive/1.3.tar.gz
- source = seperate_build_dir.patch
- md5sums = 13b716e0a3f45fe74ca24c6aaf4e5bb0
- md5sums = 16955513c1f9338aee632f4b886cf506
+ source = unshield-1.4.1.tar.gz::https://github.com/twogood/unshield/archive/1.4.1.tar.gz
+ md5sums = d9c16e3c58bcd7122d2bd2f56707b256
pkgname = mingw-w64-unshield
diff --git a/PKGBUILD b/PKGBUILD
index c6e1ebfe0944..1898c85dc9ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgname=mingw-w64-unshield
-pkgver=1.3
+pkgver=1.4.1
pkgrel=1
pkgdesc="Extracts CAB files from InstallShield installers (mingw-w64)"
arch=('any')
@@ -10,18 +10,10 @@ license=('custom')
depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-openssl')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake')
options=('!buildflags' '!strip' '!libtool' 'staticlibs')
-source=("unshield-$pkgver.tar.gz::https://github.com/twogood/unshield/archive/$pkgver.tar.gz"
- "seperate_build_dir.patch")
-md5sums=('13b716e0a3f45fe74ca24c6aaf4e5bb0'
- '16955513c1f9338aee632f4b886cf506')
+source=("unshield-$pkgver.tar.gz::https://github.com/twogood/unshield/archive/$pkgver.tar.gz")
+md5sums=('d9c16e3c58bcd7122d2bd2f56707b256')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd ${srcdir}/unshield-${pkgver}
-
- patch -p1 -i "${srcdir}/seperate_build_dir.patch"
-}
-
build() {
for _arch in ${_architectures}; do
mkdir -p ${srcdir}/build-${_arch} && cd ${srcdir}/build-${_arch}
@@ -29,6 +21,14 @@ build() {
${_arch}-cmake \
${srcdir}/unshield-${pkgver}
make
+
+ #static build
+ mkdir -p ${srcdir}/build-static-${_arch} && cd ${srcdir}/build-static-${_arch}
+
+ ${_arch}-cmake \
+ ${srcdir}/unshield-${pkgver} \
+ -DBUILD_STATIC="TRUE"
+ make
done
}
@@ -36,9 +36,12 @@ package() {
for _arch in ${_architectures}; do
cd ${srcdir}/build-${_arch}
make DESTDIR=${pkgdir} install
+ #static build
+ cd ${srcdir}/build-static-${_arch}
+ make DESTDIR=${pkgdir} install
+ ${_arch}-strip -s "${pkgdir}"/usr/${_arch}/bin/*.exe
${_arch}-strip -x -g ${pkgdir}/usr/${_arch}/bin/*.dll
${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
- rm "${pkgdir}"/usr/${_arch}/bin/*.exe
rm -r "${pkgdir}"/usr/${_arch}/share
done
}
diff --git a/seperate_build_dir.patch b/seperate_build_dir.patch
deleted file mode 100644
index 6ff8d5de4db1..000000000000
--- a/seperate_build_dir.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ruN unshield-1.3/CMakeLists.txt patched/CMakeLists.txt
---- unshield-1.3/CMakeLists.txt 2015-06-22 17:49:58.000000000 +0200
-+++ patched/CMakeLists.txt 2015-10-30 16:28:24.293769315 +0100
-@@ -68,4 +68,4 @@
- add_subdirectory(src)
-
- install(FILES man/unshield.1 DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/man/man1)
--install(FILES libunshield.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libunshield.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-diff -ruN unshield-1.3/lib/CMakeLists.txt patched/lib/CMakeLists.txt
---- unshield-1.3/lib/CMakeLists.txt 2015-06-22 17:49:58.000000000 +0200
-+++ patched/lib/CMakeLists.txt 2015-10-30 16:24:13.199282935 +0100
-@@ -30,6 +30,8 @@
-
- add_library(libunshield ${LIBUNSHIELD_LIBRARY_TYPE} ${LIBUNSHIELD_HEADES} ${LIBUNSHIELD_SOURCES})
-
-+target_include_directories(libunshield PUBLIC "${CMAKE_CURRENT_BINARY_DIR}")
-+
- if(USE_OUR_OWN_MD5)
- target_link_libraries(libunshield ${ZLIB_LIBRARY} md5 convert_utf)
- else()