summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2015-10-30 16:32:06 +0100
committerkfg2015-10-30 16:38:15 +0100
commit8ab55dc1f708124b73ce4d45e25030f582767e12 (patch)
tree168a0f3ba7b04590332ba5187f56a55c6073acfb
parent6b566ab37015e479b611c10a1480a9fcb27318b6 (diff)
downloadaur-8ab55dc1f708124b73ce4d45e25030f582767e12.tar.gz
Added patch for building in seperate build directories
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
-rw-r--r--seperate_build_dir.patch21
3 files changed, 33 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6e1b85d563a..a9ad83536cf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,9 @@ pkgbase = mingw-w64-unshield
options = !libtool
options = staticlibs
source = unshield-1.3.tar.gz::https://github.com/twogood/unshield/archive/1.3.tar.gz
+ source = seperate_build_dir.patch
md5sums = 13b716e0a3f45fe74ca24c6aaf4e5bb0
+ md5sums = 16955513c1f9338aee632f4b886cf506
pkgname = mingw-w64-unshield
diff --git a/PKGBUILD b/PKGBUILD
index 2853dc6536bb..c6e1ebfe0944 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,18 @@ license=('custom')
depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-openssl')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake')
options=('!buildflags' '!strip' '!libtool' 'staticlibs')
-source=("unshield-$pkgver.tar.gz::https://github.com/twogood/unshield/archive/$pkgver.tar.gz")
-md5sums=('13b716e0a3f45fe74ca24c6aaf4e5bb0')
+source=("unshield-$pkgver.tar.gz::https://github.com/twogood/unshield/archive/$pkgver.tar.gz"
+ "seperate_build_dir.patch")
+md5sums=('13b716e0a3f45fe74ca24c6aaf4e5bb0'
+ '16955513c1f9338aee632f4b886cf506')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd ${srcdir}/unshield-${pkgver}
+
+ patch -p1 -i "${srcdir}/seperate_build_dir.patch"
+}
+
build() {
for _arch in ${_architectures}; do
mkdir -p ${srcdir}/build-${_arch} && cd ${srcdir}/build-${_arch}
diff --git a/seperate_build_dir.patch b/seperate_build_dir.patch
new file mode 100644
index 000000000000..6ff8d5de4db1
--- /dev/null
+++ b/seperate_build_dir.patch
@@ -0,0 +1,21 @@
+diff -ruN unshield-1.3/CMakeLists.txt patched/CMakeLists.txt
+--- unshield-1.3/CMakeLists.txt 2015-06-22 17:49:58.000000000 +0200
++++ patched/CMakeLists.txt 2015-10-30 16:28:24.293769315 +0100
+@@ -68,4 +68,4 @@
+ add_subdirectory(src)
+
+ install(FILES man/unshield.1 DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/man/man1)
+-install(FILES libunshield.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libunshield.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+diff -ruN unshield-1.3/lib/CMakeLists.txt patched/lib/CMakeLists.txt
+--- unshield-1.3/lib/CMakeLists.txt 2015-06-22 17:49:58.000000000 +0200
++++ patched/lib/CMakeLists.txt 2015-10-30 16:24:13.199282935 +0100
+@@ -30,6 +30,8 @@
+
+ add_library(libunshield ${LIBUNSHIELD_LIBRARY_TYPE} ${LIBUNSHIELD_HEADES} ${LIBUNSHIELD_SOURCES})
+
++target_include_directories(libunshield PUBLIC "${CMAKE_CURRENT_BINARY_DIR}")
++
+ if(USE_OUR_OWN_MD5)
+ target_link_libraries(libunshield ${ZLIB_LIBRARY} md5 convert_utf)
+ else()