summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-05-19 09:02:41 +0200
committerMichel Zou2020-05-19 09:02:41 +0200
commit8524e398b35bf2fa031c68f6c5b66702f4316537 (patch)
treea1436e2e6867f289f20a90936122163960f3d919
parentf3882dcd227cad08f62d083a3da6e54ee462f584 (diff)
downloadaur-8524e398b35bf2fa031c68f6c5b66702f4316537.tar.gz
3.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50d07dec7fac..4a3f4630f413 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-utf8cpp
pkgdesc = UTF-8 with C++ in a Portable Way (mingw-w64)
- pkgver = 3.1
+ pkgver = 3.1.1
pkgrel = 1
url = https://github.com/nemtrif/utfcpp
arch = any
@@ -9,8 +9,8 @@ pkgbase = mingw-w64-utf8cpp
options = !buildflags
options = staticlibs
options = !strip
- source = https://github.com/nemtrif/utfcpp/archive/v3.1.tar.gz
- sha256sums = ab531c3fd5d275150430bfaca01d7d15e017a188183be932322f2f651506b096
+ source = https://github.com/nemtrif/utfcpp/archive/v3.1.1.tar.gz
+ sha256sums = 33496a4c3cc2de80e9809c4997052331af5fb32079f43ab4d667cd48c3a36e88
pkgname = mingw-w64-utf8cpp
diff --git a/PKGBUILD b/PKGBUILD
index 1dc37b43030a..5483a64c15c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-utf8cpp
-pkgver=3.1
+pkgver=3.1.1
pkgrel=1
pkgdesc="UTF-8 with C++ in a Portable Way (mingw-w64)"
url="https://github.com/nemtrif/utfcpp"
@@ -9,7 +9,7 @@ depends=()
makedepends=('mingw-w64-cmake')
options=('!buildflags' 'staticlibs' '!strip')
source=("https://github.com/nemtrif/utfcpp/archive/v${pkgver}.tar.gz")
-sha256sums=('ab531c3fd5d275150430bfaca01d7d15e017a188183be932322f2f651506b096')
+sha256sums=('33496a4c3cc2de80e9809c4997052331af5fb32079f43ab4d667cd48c3a36e88')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -18,8 +18,7 @@ build() {
cd "utfcpp-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- # https://github.com/nemtrif/utfcpp/pull/40
- ${_arch}-cmake -DUTF8_TESTS=OFF -DCYGWIN=1 -DUTF8_SAMPLES=OFF ..
+ ${_arch}-cmake -DUTF8_TESTS=OFF -DUTF8_SAMPLES=OFF ..
make
popd
done