summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-09-14 22:11:03 +0200
committerMartchus2016-09-14 22:11:03 +0200
commitcc19faffeadc57dc88ed65df3766c6b5e6ea2843 (patch)
treefac7313b47e20d8810f54a21f7cb93dd02353bdb
parentaf182389156a5392982622b8eaae410c322c0e9c (diff)
downloadaur-cc19faffeadc57dc88ed65df3766c6b5e6ea2843.tar.gz
Update version
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cc97533712f..6e3c414e32cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Apr 26 20:06:10 UTC 2016
+# Wed Sep 14 20:10:54 UTC 2016
pkgbase = mingw-w64-videodownloader
- pkgdesc = A video downloader with Qt GUI (currently only YouTube and Vimeo are maintained, git version).
- pkgver = 1.3.1
+ pkgdesc = A video downloader with Qt GUI (currently only YouTube and Vimeo are maintained, mingw-w64)
+ pkgver = 1.3.2
pkgrel = 1
url = https://github.com/Martchus/videodownloader
arch = any
@@ -18,8 +18,8 @@ pkgbase = mingw-w64-videodownloader
options = staticlibs
options = !strip
options = !emptydirs
- source = videodownloader-1.3.1.tar.gz::https://github.com/Martchus/videodownloader/archive/v1.3.1.tar.gz
- sha256sums = 122a64f4d08caa2e1cca1dd279d4db85023d46ee9f12b041b341b8d7c33dea9d
+ source = videodownloader-1.3.2.tar.gz::https://github.com/Martchus/videodownloader/archive/v1.3.2.tar.gz
+ sha256sums = 4f2ffc1762b6f3fda50c7d1b5673e85e2dbfea50543f3219792f6126a30e1bce
pkgname = mingw-w64-videodownloader
diff --git a/PKGBUILD b/PKGBUILD
index 41d85ef9098b..0f46485c8ed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,24 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-_name=videodownloader
_reponame=videodownloader
pkgname=mingw-w64-videodownloader
-pkgver=1.3.1
+_name=${pkgname#mingw-w64-}
+pkgver=1.3.2
pkgrel=1
arch=('any')
-pkgdesc="A video downloader with Qt GUI (currently only YouTube and Vimeo are maintained, git version)."
+pkgdesc='A video downloader with Qt GUI (currently only YouTube and Vimeo are maintained, mingw-w64)'
license=('GPL')
depends=('mingw-w64-crt' 'mingw-w64-qtutilities' 'mingw-w64-openssl')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
url="https://github.com/Martchus/${_reponame}"
-source=("videodownloader-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('122a64f4d08caa2e1cca1dd279d4db85023d46ee9f12b041b341b8d7c33dea9d')
+source=("${_reponame}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
+sha256sums=('4f2ffc1762b6f3fda50c7d1b5673e85e2dbfea50543f3219792f6126a30e1bce')
options=(!buildflags staticlibs !strip !emptydirs)
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- # build utilities for each architecture
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr/${_arch}" ../