summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-10-20 18:36:31 +0200
committerMichel Zou2020-10-20 18:36:31 +0200
commit93b0a41ba138fd8da5fdc35ae20f4ae4b738c944 (patch)
tree162d7e92508947c914fc5a209c609e94e4bad966
parent30d49e213ebd690404704e137718b732d56d5740 (diff)
downloadaur-93b0a41ba138fd8da5fdc35ae20f4ae4b738c944.tar.gz
1.2.158
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 9 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a80e7c44e201..fc9036176d31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = mingw-w64-vulkan-headers
pkgdesc = Vulkan header files (mingw-w64)
- pkgver = 1.2.131
+ pkgver = 1.2.158
pkgrel = 1
url = https://www.khronos.org/vulkan/
arch = any
groups = mingw-w64-vulkan-devel
license = APACHE
makedepends = mingw-w64-cmake
- provides = mingw-w64-vulkan-hpp=1.2.131
options = !buildflags
options = staticlibs
options = !strip
- options = !emptydirs
- source = Vulkan-Headers-1.2.131.tar.gz::https://github.com/KhronosGroup/Vulkan-Headers/archive/v1.2.131.tar.gz
- sha512sums = b214e517decd508e9811eab18c72b58a8f77dadef865cfbad5cbb6b255711a7606837824026bb8052480952dc75bd8e17786cbbe00ff8692a1d77a26ea1a7a88
+ source = https://github.com/KhronosGroup/Vulkan-Headers/archive/v1.2.158.tar.gz
+ sha256sums = 53361271cfe274df8782e1e47bdc9e61b7af432ba30acbfe31723f9df2c257f3
pkgname = mingw-w64-vulkan-headers
diff --git a/PKGBUILD b/PKGBUILD
index de0cf8da79ea..eeedec2601f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,32 @@
-# Contributor: luigoalma <at gmail>
-# Contributor: PedroHLC <root@pedrohlc.com>
-# Contributor: J. Peter Mugaas <jpmugaas@suddenlink.net>
-# Contributor: wirx6 <wirx654@gmail.com>
-# based of https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/vulkan-headers @ be8e4b4
-
pkgname=mingw-w64-vulkan-headers
_pkgname=Vulkan-Headers
-pkgver=1.2.131
+pkgver=1.2.158
pkgrel=1
pkgdesc="Vulkan header files (mingw-w64)"
arch=(any)
url="https://www.khronos.org/vulkan/"
license=('APACHE')
makedepends=(mingw-w64-cmake)
-provides=("mingw-w64-vulkan-hpp=${pkgver}")
groups=("mingw-w64-vulkan-devel")
-options=(!buildflags staticlibs !strip !emptydirs)
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('b214e517decd508e9811eab18c72b58a8f77dadef865cfbad5cbb6b255711a7606837824026bb8052480952dc75bd8e17786cbbe00ff8692a1d77a26ea1a7a88')
+options=(!buildflags staticlibs !strip)
+source=("https://github.com/KhronosGroup/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('53361271cfe274df8782e1e47bdc9e61b7af432ba30acbfe31723f9df2c257f3')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
-
for _arch in ${_architectures}; do
mkdir build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake \
- -DCMAKE_BUILD_TYPE=Release \
- ..
+ ${_arch}-cmake ..
make
popd
done
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
-
for _arch in ${_architectures}; do
- pushd build-${_arch}
+ cd "${srcdir}"/${_pkgname}-${pkgver}/build-${_arch}
make DESTDIR="${pkgdir}" install
- popd
- install -Dm644 "LICENSE.txt" "${pkgdir}/usr/${_arch}/share/licenses/vulkan-headers/LICENSE"
done
}