summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-10-20 20:18:49 +0200
committerMichel Zou2020-10-20 20:18:49 +0200
commitc59db3b3ef5b13df1369700625314cf253833109 (patch)
treeda339dc77b7d4bcdc871fe84beadcf498723f3ba
parenta9f515d856c1dccde6b87f89f853acfffb7a3e5b (diff)
downloadaur-c59db3b3ef5b13df1369700625314cf253833109.tar.gz
constexpr
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd9548d1280b..0324f531d346 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,9 @@ pkgbase = mingw-w64-vulkan-headers
options = staticlibs
options = !strip
source = https://github.com/KhronosGroup/Vulkan-Headers/archive/v1.2.157.tar.gz
+ source = https://github.com/KhronosGroup/Vulkan-Headers/pull/155.patch
sha256sums = dbc121f58641acd45c386ee96ecd5e10a124c489087443d7367fff4b53b49283
+ sha256sums = SKIP
pkgname = mingw-w64-vulkan-headers
diff --git a/PKGBUILD b/PKGBUILD
index ef4092d3611c..9862ce5d7089 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,11 +9,17 @@ license=('APACHE')
makedepends=(mingw-w64-cmake)
groups=("mingw-w64-vulkan-devel")
options=(!buildflags staticlibs !strip)
-source=("https://github.com/KhronosGroup/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('dbc121f58641acd45c386ee96ecd5e10a124c489087443d7367fff4b53b49283')
+source=("https://github.com/KhronosGroup/${_pkgname}/archive/v${pkgver}.tar.gz"
+ "https://github.com/KhronosGroup/Vulkan-Headers/pull/155.patch")
+sha256sums=('dbc121f58641acd45c386ee96ecd5e10a124c489087443d7367fff4b53b49283' SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}"/155.patch
+}
+
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
for _arch in ${_architectures}; do