summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-10-20 19:52:56 +0200
committerMichel Zou2020-10-20 19:52:56 +0200
commit269452064b005190b6368fa2b8bb262b349bdab1 (patch)
tree94a722d9a8784d915624e21ea4ed10dfbfc2713d
parent0bdf5f5f14ed4837c690551013653cc2f6c7c8b6 (diff)
downloadaur-269452064b005190b6368fa2b8bb262b349bdab1.tar.gz
1.2.157
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD56
2 files changed, 19 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a618b9a79ba8..ff153591cf12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-vulkan-icd-loader
pkgdesc = Vulkan Installable Client Driver (ICD) Loader (mingw-w64)
- pkgver = 1.2.131
+ pkgver = 1.2.157
pkgrel = 1
url = https://www.khronos.org/vulkan/
arch = any
@@ -13,15 +13,12 @@ pkgbase = mingw-w64-vulkan-icd-loader
options = !buildflags
options = staticlibs
options = !strip
- options = !emptydirs
- source = Vulkan-Loader-1.2.131.tar.gz::https://github.com/KhronosGroup/Vulkan-Loader/archive/v1.2.131.tar.gz
- source = 001-build-fix.patch
- source = 002-proper-def-files-for-32bit.patch
- source = 003-generate-pkgconfig-files.patch
- sha256sums = c20976afc31337b7e97aab3b9f94a87d1e8a5bcfccb633af35aaf077463809e3
- sha256sums = e1d765334a6582e2df41986d876a578e1c978a73a741f204332f073ce20f23a7
- sha256sums = 71819784f64244b3d51666877e4437fe30786bc82db165b921a3ac029a885a9b
- sha256sums = 5c189b3f76fa53ad12077cd8932423a0cf385f9464cdde60ba711589ccde19ad
+ source = https://github.com/KhronosGroup/Vulkan-Loader/archive/v1.2.157.tar.gz
+ source = https://github.com/KhronosGroup/Vulkan-Loader/pull/495.patch
+ source = https://github.com/KhronosGroup/Vulkan-Loader/pull/496.patch
+ sha256sums = 536e70a29715ad04bbeba68802f785e72a1cf960e8dc244aa7ab1a130276f02f
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = mingw-w64-vulkan-icd-loader
diff --git a/PKGBUILD b/PKGBUILD
index c90a6b43999a..91dadad769f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,6 @@
-# Contributor: luigoalma <at gmail>
-# Contributor: PedroHLC <root@pedrohlc.com>
-# Contributor: J. Peter Mugaas <jpmugaas@suddenlink.net>
-# Contributor: wirx6 <wirx654@gmail.com>
-# based of https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/vulkan-icd-loader @ 837304b
-
pkgname=mingw-w64-vulkan-icd-loader
_pkgname=Vulkan-Loader
-pkgver=1.2.131
+pkgver=1.2.157
pkgrel=1
pkgdesc="Vulkan Installable Client Driver (ICD) Loader (mingw-w64)"
arch=(any)
@@ -15,47 +9,26 @@ groups=("mingw-w64-vulkan-devel")
license=('APACHE')
makedepends=(mingw-w64-cmake mingw-w64-vulkan-headers python-lxml)
depends=(mingw-w64-crt)
-options=(!buildflags staticlibs !strip !emptydirs)
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/${_pkgname}/archive/v${pkgver}.tar.gz"
- "001-build-fix.patch"
- "002-proper-def-files-for-32bit.patch"
- "003-generate-pkgconfig-files.patch")
-sha256sums=('c20976afc31337b7e97aab3b9f94a87d1e8a5bcfccb633af35aaf077463809e3'
- 'e1d765334a6582e2df41986d876a578e1c978a73a741f204332f073ce20f23a7'
- '71819784f64244b3d51666877e4437fe30786bc82db165b921a3ac029a885a9b'
- '5c189b3f76fa53ad12077cd8932423a0cf385f9464cdde60ba711589ccde19ad')
+options=(!buildflags staticlibs !strip)
+source=("https://github.com/KhronosGroup/${_pkgname}/archive/v${pkgver}.tar.gz"
+ "https://github.com/KhronosGroup/Vulkan-Loader/pull/495.patch"
+ "https://github.com/KhronosGroup/Vulkan-Loader/pull/496.patch")
+sha256sums=('536e70a29715ad04bbeba68802f785e72a1cf960e8dc244aa7ab1a130276f02f' SKIP SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
-
- # From the PedroHLC's aur package mingw-w64-vulkan-loader
- # which is based of https://github.com/Alexpux/MINGW-packages/blob/master/mingw-w64-vulkan-loader/PKGBUILD
- patch -p1 -i "${srcdir}/001-build-fix.patch"
- patch -p1 -i "${srcdir}/002-proper-def-files-for-32bit.patch"
- patch -p1 -i "${srcdir}/003-generate-pkgconfig-files.patch"
- cd loader
- sed -i'' -E 's/#include <([^>]+)>/#include <\L\1>/g' *.h *.c
- sed -i'' -E 's/target_link_libraries\(([^\)]+)\)/target_link_libraries\(\L\1\)/g' CMakeLists.txt
- # revert back just the vulkan::headers caused by previous sed
- sed -i'' -E 's/vulkan::headers/Vulkan::Headers/g' CMakeLists.txt
+ patch -p1 -i "${srcdir}"/495.patch
+ patch -p1 -i "${srcdir}"/496.patch
}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
-
- export LDFLAGS="-static-libgcc -static -Wl,--enable-stdcall-fixup" # -static to staticly apply libssp and libwinpthread
- export CFLAGS="-Wno-unused-function"
- export CXXFLAGS=$CFLAGS
- export CPPFLAGS=$CFLAGS
for _arch in ${_architectures}; do
- mkdir build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake \
- -DCMAKE_SHARED_LIBRARY_PREFIX_C="" \
- -DCMAKE_SHARED_LIBRARY_PREFIX_CXX="" \
- -DBUILD_TESTS=Off \
- -DCMAKE_BUILD_TYPE=Release \
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DBUILD_TESTS=OFF \
+ -DCMAKE_ASM_MASM_COMPILER=0 -DCMAKE_ASM_MASM_COMPILER_WORKS=0 \
..
make
popd
@@ -63,14 +36,9 @@ build() {
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
-
for _arch in ${_architectures}; do
- pushd build-${_arch}
+ cd "${srcdir}"/${_pkgname}-${pkgver}/build-${_arch}
make DESTDIR="${pkgdir}" install
- popd
- install -Dm644 "LICENSE.txt" "${pkgdir}/usr/${_arch}/share/licenses/vulkan-loader/LICENSE"
-
${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
done