summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-05-21 08:24:52 +0200
committerMichel Zou2019-05-21 08:24:52 +0200
commit079388e5b6d0370d000abe0e5529b875eff93419 (patch)
treeb3d070a03c2f6e3ff80e05789fc3c953078cd5c5
parentca52cce4d0e8214ba2cefe3426c04beaa99555bf (diff)
downloadaur-079388e5b6d0370d000abe0e5529b875eff93419.tar.gz
avoid popups
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--mingw-wine.sh7
3 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04e5e4f0b2b1..9175c425752b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = mingw-w64-wine
pkgdesc = Wine wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 2
+ pkgrel = 3
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = MIT
depends = wine
+ depends = xorg-server-xvfb
source = mingw-wine.sh
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c6d3b2b6db47..8e4d014c1d7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
pkgname=mingw-w64-wine
pkgver=1
-pkgrel=2
+pkgrel=3
arch=('any')
pkgdesc="Wine wrapper for MinGW (mingw-w64)"
-depends=('wine')
+depends=('wine' 'xorg-server-xvfb')
license=("MIT")
url="http://fedoraproject.org/wiki/MinGW"
source=("mingw-wine.sh")
diff --git a/mingw-wine.sh b/mingw-wine.sh
index 32ec0a495ca8..39c9ff02b2d3 100644
--- a/mingw-wine.sh
+++ b/mingw-wine.sh
@@ -22,5 +22,12 @@ else
export WINEARCH=win32
fi
+if ! test -d "${WINEPREFIX}"
+then
+ /usr/bin/xvfb-run wineboot --init
+fi
+
+export WINEDLLOVERRIDES="mscoree,mshtml="
+
/usr/bin/wine "$@"