summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-06-05 21:34:48 +0200
committerMichel Zou2019-06-05 21:34:48 +0200
commit88e281dda8ddfc9bdb8eef11bec245ec32a51bf4 (patch)
treee6ba2dfb7296094a7c1a027c561fd17023a934bc
parentdd79579379f5a92c0f8fb3a0f67eec6c2a4d18b5 (diff)
downloadaur-88e281dda8ddfc9bdb8eef11bec245ec32a51bf4.tar.gz
add msiexec wrapper
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--mingw-msiexec.sh19
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd010f90cc6f..c42993eb69fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = mingw-w64-wine
pkgdesc = Wine wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 4
+ pkgrel = 5
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = MIT
depends = wine
source = mingw-wine.sh
+ source = mingw-msiexec.sh
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = mingw-w64-wine
diff --git a/PKGBUILD b/PKGBUILD
index 1c9480f73457..e1e5c4a8eec0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
pkgname=mingw-w64-wine
pkgver=1
-pkgrel=4
+pkgrel=5
arch=('any')
pkgdesc="Wine wrapper for MinGW (mingw-w64)"
depends=('wine')
license=("MIT")
url="http://fedoraproject.org/wiki/MinGW"
-source=("mingw-wine.sh")
-sha256sums=('SKIP')
+source=("mingw-wine.sh" "mingw-msiexec.sh")
+sha256sums=('SKIP' 'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
for _arch in ${_architectures}; do
sed "s|@TRIPLE@|${_arch}|g" mingw-wine.sh > ${_arch}-wine
+ sed "s|@TRIPLE@|${_arch}|g" mingw-msiexec.sh > ${_arch}-msiexec
done
}
@@ -21,6 +22,7 @@ package() {
install -d "${pkgdir}"/usr/bin
for _arch in ${_architectures}; do
install -m 755 ${_arch}-wine "${pkgdir}"/usr/bin/
+ install -m 755 ${_arch}-msiexec "${pkgdir}"/usr/bin/
done
}
diff --git a/mingw-msiexec.sh b/mingw-msiexec.sh
new file mode 100644
index 000000000000..a2723d696ba2
--- /dev/null
+++ b/mingw-msiexec.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+set -e
+
+mingw_prefix=/usr/@TRIPLE@
+
+# run it in a custom WINEPREFIX to not mess with default ~/.wine
+# also default prefix might be a 32 bits prefix, which will fail to run x86_64 exes
+export WINEPREFIX=${HOME}/.wine-@TRIPLE@
+
+if test "@TRIPLE@" = "x86_64-w64-mingw32"
+then
+ export WINEARCH=win64
+else
+ export WINEARCH=win32
+fi
+
+/usr/bin/msiexec "$@"
+