summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-09-28 20:39:15 +0200
committerMichel Zou2020-09-28 20:39:15 +0200
commit8ca7f43ca99323c847996365c6355a431c331d65 (patch)
treeaa3fd328bb577ef51f04bc617bd21b31ae7072d9
parent88e281dda8ddfc9bdb8eef11bec245ec32a51bf4 (diff)
downloadaur-8ca7f43ca99323c847996365c6355a431c331d65.tar.gz
lock
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--mingw-wine.sh11
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c42993eb69fe..21b098d18cb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = mingw-w64-wine
pkgdesc = Wine wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 5
+ pkgrel = 6
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = MIT
depends = wine
+ depends = lockfile-progs
source = mingw-wine.sh
source = mingw-msiexec.sh
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e1e5c4a8eec0..7d6033f7dabc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
pkgname=mingw-w64-wine
pkgver=1
-pkgrel=5
+pkgrel=6
arch=('any')
pkgdesc="Wine wrapper for MinGW (mingw-w64)"
-depends=('wine')
+depends=('wine' 'lockfile-progs')
license=("MIT")
url="http://fedoraproject.org/wiki/MinGW"
source=("mingw-wine.sh" "mingw-msiexec.sh")
diff --git a/mingw-wine.sh b/mingw-wine.sh
index 7cb8498caada..e0282fd3ee70 100644
--- a/mingw-wine.sh
+++ b/mingw-wine.sh
@@ -24,5 +24,12 @@ fi
export WINEDLLOVERRIDES="mscoree,mshtml="
-/usr/bin/wine "$@"
-
+# if MINGW_WINE_LOCK is set, only one wine process is allowed at once
+if test -n "${MINGW_WINE_LOCK}"
+then
+ /usr/bin/lockfile-create ${WINEPREFIX}
+ /usr/bin/wine "$@"
+ /usr/bin/lockfile-remove ${WINEPREFIX}
+else
+ /usr/bin/wine "$@"
+fi