summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-06-11 08:25:40 +0200
committerMichel Zou2022-06-11 08:25:40 +0200
commitbc03a0b072383dac842a4e6165a3e57740efc4e2 (patch)
tree7fd20d7379b7540e6d32282b3712e376b2119549
parentcfc1aff5a8f2c9079f1d4b0a5c0f8c1b90b58ea5 (diff)
downloadaur-bc03a0b072383dac842a4e6165a3e57740efc4e2.tar.gz
winepath
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--mingw-msiexec.sh10
-rw-r--r--mingw-winepath.sh34
4 files changed, 52 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7731366d323a..e1fc84a5febc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = mingw-w64-wine
pkgdesc = Wine wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 8
+ pkgrel = 9
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = MIT
depends = wine
source = mingw-wine.sh
source = mingw-msiexec.sh
+ source = mingw-winepath.sh
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3db219e428f8..e0d3424ac4e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=mingw-w64-wine
pkgver=1
-pkgrel=8
+pkgrel=9
arch=('any')
pkgdesc="Wine wrapper for MinGW (mingw-w64)"
depends=('wine')
license=("MIT")
url="http://fedoraproject.org/wiki/MinGW"
-source=("mingw-wine.sh" "mingw-msiexec.sh")
-sha256sums=('SKIP' 'SKIP')
+source=("mingw-wine.sh" "mingw-msiexec.sh" "mingw-winepath.sh")
+sha256sums=('SKIP' 'SKIP' 'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -15,6 +15,7 @@ build() {
for _arch in ${_architectures}; do
sed "s|@TRIPLE@|${_arch}|g" mingw-wine.sh > ${_arch}-wine
sed "s|@TRIPLE@|${_arch}|g" mingw-msiexec.sh > ${_arch}-msiexec
+ sed "s|@TRIPLE@|${_arch}|g" mingw-winepath.sh > ${_arch}-winepath
done
}
@@ -23,6 +24,7 @@ package() {
for _arch in ${_architectures}; do
install -m 755 ${_arch}-wine "${pkgdir}"/usr/bin/
install -m 755 ${_arch}-msiexec "${pkgdir}"/usr/bin/
+ install -m 755 ${_arch}-winepath "${pkgdir}"/usr/bin/
done
}
diff --git a/mingw-msiexec.sh b/mingw-msiexec.sh
index a2723d696ba2..ca15837ec174 100644
--- a/mingw-msiexec.sh
+++ b/mingw-msiexec.sh
@@ -15,5 +15,15 @@ else
export WINEARCH=win32
fi
+if test -z ${WINEDLLOVERRIDES+x}
+then
+ export WINEDLLOVERRIDES="mscoree,mshtml="
+fi
+
+if test -z ${WINEDEBUG+x}
+then
+ export WINEDEBUG=-all
+fi
+
/usr/bin/msiexec "$@"
diff --git a/mingw-winepath.sh b/mingw-winepath.sh
new file mode 100644
index 000000000000..ebbaa3b1e46c
--- /dev/null
+++ b/mingw-winepath.sh
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+set -e
+
+mingw_prefix=/usr/@TRIPLE@
+
+# run it in a custom WINEPREFIX to not mess with default ~/.wine
+# also default prefix might be a 32 bits prefix, which will fail to run x86_64 exes
+export WINEPREFIX=${HOME}/.wine-@TRIPLE@
+
+# WINEPATH is used to find dlls, otherwise they should lie next to the exe
+if test -z ${WINEPATH+x}
+then
+ export WINEPATH=${mingw_prefix}/bin
+fi
+
+if test "@TRIPLE@" = "x86_64-w64-mingw32"
+then
+ export WINEARCH=win64
+else
+ export WINEARCH=win32
+fi
+
+if test -z ${WINEDLLOVERRIDES+x}
+then
+ export WINEDLLOVERRIDES="mscoree,mshtml="
+fi
+
+if test -z ${WINEDEBUG+x}
+then
+ export WINEDEBUG=-all
+fi
+
+/usr/bin/winepath "$@"