summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-11-10 12:55:16 +0100
committerMichel Zou2019-11-10 12:55:16 +0100
commit0ee6e57dd7c4600defbb47dcf727848c198c9e97 (patch)
treee15c245e1ba1574f0411a38e22d226fc1ede2340
parentefbab7fdd46ac86cf5f921861bdc38896d8b6d24 (diff)
downloadaur-0ee6e57dd7c4600defbb47dcf727848c198c9e97.tar.gz
7.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e38914c7447b..f5abe55271eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-winpthreads
pkgdesc = MinGW-w64 winpthreads library
- pkgver = 6.0.0
+ pkgver = 7.0.0
pkgrel = 1
url = http://mingw-w64.sourceforge.net
arch = any
@@ -17,10 +17,10 @@ pkgbase = mingw-w64-winpthreads
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/mingw-w64-v6.0.0.tar.bz2
- source = https://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/mingw-w64-v6.0.0.tar.bz2.sig
+ source = https://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/mingw-w64-v7.0.0.tar.bz2
+ source = https://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/mingw-w64-v7.0.0.tar.bz2.sig
validpgpkeys = CAF5641F74F7DFBA88AE205693BDB53CD4EBC740
- sha256sums = 805e11101e26d7897fce7d49cbb140d7bac15f3e085a91e0001e80b2adaf48f0
+ sha256sums = f5c9a04e1a6c02c9ef2ec19b3906ec4613606d1b5450d34bbd3c4d94ac696b3b
sha256sums = SKIP
pkgname = mingw-w64-winpthreads
diff --git a/PKGBUILD b/PKGBUILD
index 42f6ff8e7f3e..6c4b61afce66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,5 @@
-# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Contributor: rubenvb vanboxem <dottie> ruben <attie> gmail <dottie> com
-
-_targets="i686-w64-mingw32 x86_64-w64-mingw32"
-
pkgname=mingw-w64-winpthreads
-pkgver=6.0.0
+pkgver=7.0.0
pkgrel=1
pkgdesc='MinGW-w64 winpthreads library'
arch=('any')
@@ -18,14 +13,16 @@ replaces=('mingw-w64-headers-bootstrap')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
validpgpkeys=('CAF5641F74F7DFBA88AE205693BDB53CD4EBC740')
source=(https://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/mingw-w64-v${pkgver}.tar.bz2{,.sig})
-sha256sums=('805e11101e26d7897fce7d49cbb140d7bac15f3e085a91e0001e80b2adaf48f0'
+sha256sums=('f5c9a04e1a6c02c9ef2ec19b3906ec4613606d1b5450d34bbd3c4d94ac696b3b'
'SKIP')
+_targets="i686-w64-mingw32 x86_64-w64-mingw32"
+
build() {
for _target in ${_targets}; do
msg "Building ${_target} winpthreads..."
mkdir -p "$srcdir"/winpthreads-build-${_target} && cd "$srcdir"/winpthreads-build-${_target}
- "$srcdir"/mingw-w64-v${pkgver}/mingw-w64-libraries/winpthreads/configure --prefix=/usr/${_target} \
+ "$srcdir"/mingw-w64-v6.0.0/mingw-w64-libraries/winpthreads/configure --prefix=/usr/${_target} \
--host=${_target} --enable-static --enable-shared
make
done