summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author4shadoww2018-03-21 23:02:39 +0200
committer4shadoww2018-03-21 23:02:39 +0200
commite91e79c4d3080233f227750ece36977762ddad4d (patch)
tree9200595e41a666a7fd76544e5d0ff09db315e591
downloadaur-e91e79c4d3080233f227750ece36977762ddad4d.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD20
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65964d1068f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mingw-w64-winpthreads-bin
+ pkgdesc = MinGW-w64 winpthreads library (pre-compiled)
+ pkgver = 5.0.3
+ pkgrel = 1
+ url = http://mingw-w64.sourceforge.net
+ arch = any
+ groups = mingw-w64-toolchain
+ groups = mingw-w64
+ license = custom
+ provides = mingw-w64-winpthreads
+ conflicts = mingw-w64-winpthreads
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/4shadoww/mingw-w64-builds/releases/download/binary/mingw-w64-winpthreads-5.0.3.tar.xz
+ md5sums = 2088b38c5194bdda533a88dc6a214cdb
+
+pkgname = mingw-w64-winpthreads-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a530595d73c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Noa-Emil Nissinen <aur dot satella at spamgourmet dot org>
+
+pkgname=mingw-w64-winpthreads-bin
+pkgver=5.0.3
+pkgrel=1
+pkgdesc="MinGW-w64 winpthreads library (pre-compiled)"
+arch=('any')
+url="http://mingw-w64.sourceforge.net"
+license=('custom')
+groups=('mingw-w64-toolchain' 'mingw-w64')
+provides=('mingw-w64-winpthreads')
+conflicts=('mingw-w64-winpthreads')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+source=("https://github.com/4shadoww/mingw-w64-builds/releases/download/binary/$provides-$pkgver.tar.xz")
+md5sums=("2088b38c5194bdda533a88dc6a214cdb")
+
+package() {
+ cd "$provides/"
+ cp -r * "$pkgdir/"
+}