summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Puntiy2014-10-06 12:28:06 +0300
committerIvan Puntiy2014-10-06 12:28:06 +0300
commite9d9dcc2c4b829476334dd9a3681ea7fe3cf59f1 (patch)
tree4def46a89747e8b072ece9aa2f4232f24fb0c0e5
downloadaur-e9d9dcc2c4b829476334dd9a3681ea7fe3cf59f1.tar.gz
mingw-w64-wxmsw 3.0.1-2
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD95
2 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cdf60c7956d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mingw-w64-wxmsw
+ pkgdesc = Win32 implementation of wxWidgets API for GUI (mingw-w64)
+ pkgver = 3.0.1
+ pkgrel = 2
+ epoch = 1
+ url = http://wxwidgets.org
+ arch = any
+ license = custom:wxWindows
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-crt
+ depends = mingw-w64-libpng
+ depends = mingw-w64-libjpeg-turbo
+ depends = mingw-w64-libtiff
+ provides = mingw-w64-wxmsw2.9
+ provides = mingw-w64-wxmsw-static
+ conflicts = mingw-w64-wxmsw2.9
+ conflicts = mingw-w64-wxmsw-static
+ replaces = mingw-w64-wxmsw2.9
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://downloads.sourceforge.net/wxwindows/wxWidgets-3.0.1.tar.bz2
+ sha1sums = 73e58521d6871c9f4d1e7974c6e3a81629fddcf8
+
+pkgname = mingw-w64-wxmsw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..158234d926c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,95 @@
+# Maintainer: Ivan Puntiy <ivan.puntiy-at-gmail>
+# Contributor: Schala
+
+pkgname=mingw-w64-wxmsw
+epoch=1
+pkgver=3.0.1
+pkgrel=2
+pkgdesc="Win32 implementation of wxWidgets API for GUI (mingw-w64)"
+arch=(any)
+url="http://wxwidgets.org"
+license=("custom:wxWindows")
+makedepends=(mingw-w64-gcc)
+depends=(mingw-w64-crt mingw-w64-libpng mingw-w64-libjpeg-turbo mingw-w64-libtiff)
+options=(staticlibs !strip !buildflags)
+conflicts=(mingw-w64-wxmsw2.9 mingw-w64-wxmsw-static)
+provides=(mingw-w64-wxmsw2.9 mingw-w64-wxmsw-static)
+replaces=(mingw-w64-wxmsw2.9)
+source=("http://downloads.sourceforge.net/wxwindows/wxWidgets-${pkgver}.tar.bz2")
+sha1sums=('73e58521d6871c9f4d1e7974c6e3a81629fddcf8')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ # monolithic shared builds
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-shared-${_arch}"
+ cd "${srcdir}/${pkgname}-${pkgver}-build-shared-${_arch}"
+ "${srcdir}"/wxWidgets-$pkgver/configure \
+ --prefix=/usr/${_arch} \
+ --build=$CHOST \
+ --host=${_arch} \
+ --with-msw \
+ --with-opengl \
+ --disable-mslu \
+ --enable-unicode \
+ --enable-shared \
+ --enable-monolithic \
+ --enable-stl \
+ --with-regex=builtin \
+ --disable-precomp-headers \
+ --enable-graphics_ctx \
+ --enable-webview \
+ --enable-mediactrl \
+ --with-libpng=sys \
+ --with-libxpm=builtin \
+ --with-libjpeg=sys \
+ --with-libtiff=sys
+ make
+ done
+
+ # static builds
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-static-${_arch}"
+ cd "${srcdir}/${pkgname}-${pkgver}-build-static-${_arch}"
+ "${srcdir}"/wxWidgets-$pkgver/configure \
+ --prefix=/usr/${_arch} \
+ --build=$CHOST \
+ --host=${_arch} \
+ --with-msw \
+ --with-opengl \
+ --disable-mslu \
+ --enable-unicode \
+ --disable-shared \
+ --enable-stl \
+ --with-regex=builtin \
+ --disable-precomp-headers \
+ --enable-graphics_ctx \
+ --enable-webview \
+ --enable-mediactrl \
+ --with-libpng=sys \
+ --with-libxpm=builtin \
+ --with-libjpeg=sys \
+ --with-libtiff=sys
+ make
+ done
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ for _arch in ${_architectures}; do
+ for _build in "shared" "static"; do
+ cd "${srcdir}/${pkgname}-${pkgver}-build-${_build}-${_arch}"
+ make DESTDIR="$pkgdir" install
+ done
+ mv "$pkgdir/usr/${_arch}/lib/"*.dll "$pkgdir/usr/${_arch}/bin"
+ find "$pkgdir/usr/${_arch}" -name '*.exe' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ ln -s "/usr/${_arch}/lib/wx/config/${_arch}-msw-unicode-${pkgver%.*}" "$pkgdir/usr/bin/${_arch}-wx-config"
+ rm "$pkgdir/usr/${_arch}/bin/wxrc-3.0"
+ rm -r "$pkgdir/usr/${_arch}/share"
+ done
+}