summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2017-08-17 16:48:11 +0200
committerkfg2017-08-17 17:06:32 +0200
commit9d8bf0e5600b15a7dbd47ef5408c9f09cf4d0725 (patch)
tree4973e657cfda475c0856e00dba83afd9cf6260dd
parent397a1fad13c33a6d8d6e6ac1760db6d9fb219309 (diff)
downloadaur-9d8bf0e5600b15a7dbd47ef5408c9f09cf4d0725.tar.gz
upgpkg: mingw-w64-x265 2.5-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD7
-rw-r--r--mingw.patch44
3 files changed, 32 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffd9c9106f8e..fb221e705dd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu May 11 17:51:27 UTC 2017
+# Thu Aug 17 15:06:25 UTC 2017
pkgbase = mingw-w64-x265
pkgdesc = Open Source H265/HEVC video encoder (mingw-w64)
- pkgver = 2.4
+ pkgver = 2.5
pkgrel = 1
url = https://bitbucket.org/multicoreware/x265
arch = any
@@ -13,10 +13,10 @@ pkgbase = mingw-w64-x265
options = !strip
options = !buildflags
options = staticlibs
- source = https://bitbucket.org/multicoreware/x265/downloads/x265_2.4.tar.gz
+ source = https://bitbucket.org/multicoreware/x265/downloads/x265_2.5.tar.gz
source = mingw.patch
- sha256sums = 9c2aa718d78f6fecdd783f08ab83b98d3169e5f670404da4c16439306907d729
- sha256sums = 90b8e81cd5228d2b147fbd6c000921d5b7593819e378d0e73c11c8de390796bc
+ sha256sums = 2e53259b504a7edb9b21b9800163b1ff4c90e60c74e23e7001d423c69c5d3d17
+ sha256sums = b1953c70b734b91e7916448c4636b70305c1d5bfaf86f17f94b769499635a191
pkgname = mingw-w64-x265
diff --git a/PKGBUILD b/PKGBUILD
index f33983565498..6793a5cd330d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgname=mingw-w64-x265
-pkgver=2.4
+pkgver=2.5
pkgrel=1
pkgdesc='Open Source H265/HEVC video encoder (mingw-w64)'
arch=('any')
@@ -12,8 +12,8 @@ options=(!strip !buildflags staticlibs)
makedepends=('mingw-w64-cmake' 'yasm')
source=("https://bitbucket.org/multicoreware/x265/downloads/x265_${pkgver}.tar.gz"
mingw.patch)
-sha256sums=('9c2aa718d78f6fecdd783f08ab83b98d3169e5f670404da4c16439306907d729'
- '90b8e81cd5228d2b147fbd6c000921d5b7593819e378d0e73c11c8de390796bc')
+sha256sums=('2e53259b504a7edb9b21b9800163b1ff4c90e60c74e23e7001d423c69c5d3d17'
+ 'b1953c70b734b91e7916448c4636b70305c1d5bfaf86f17f94b769499635a191')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
@@ -57,6 +57,7 @@ build() {
${_arch}-cmake \
-DLIB_INSTALL_DIR="lib" \
-DENABLE_SHARED='TRUE' \
+ -DENABLE_HDR10_PLUS='TRUE' \
-DEXTRA_LIB='x265_main10.a;x265_main12.a' \
-DEXTRA_LINK_FLAGS='-L.' \
-DLINKED_10BIT='TRUE' \
diff --git a/mingw.patch b/mingw.patch
index 459220768efb..eb666e0c3ec8 100644
--- a/mingw.patch
+++ b/mingw.patch
@@ -1,20 +1,22 @@
-diff -ru multicoreware-x265-d6257335c537/source/CMakeLists.txt patched/source/CMakeLists.txt
---- multicoreware-x265-d6257335c537/source/CMakeLists.txt 2014-07-09 10:25:15.000000000 +0200
-+++ patched/source/CMakeLists.txt 2014-07-11 02:30:52.574683624 +0200
-@@ -283,6 +283,7 @@
- # shared library is not installed if a tag is not found
- set_target_properties(x265-shared PROPERTIES VERSION ${X265_LATEST_TAG} SOVERSION ${X265_BUILD})
- install(TARGETS x265-shared
-+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}
- LIBRARY DESTINATION ${LIB_INSTALL_DIR}
- ARCHIVE DESTINATION ${LIB_INSTALL_DIR})
+diff -ruN x265_2.5/source/CMakeLists.txt patched/source/CMakeLists.txt
+--- x265_2.5/source/CMakeLists.txt 2017-07-13 13:20:07.000000000 +0200
++++ patched/source/CMakeLists.txt 2017-08-17 17:04:43.903541062 +0200
+@@ -607,7 +607,8 @@
+ if(ENABLE_HDR10_PLUS)
+ install(TARGETS hdr10plus-shared
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+- ARCHIVE DESTINATION ${LIB_INSTALL_DIR})
++ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
++ RUNTIME DESTINATION ${BIN_INSTALL_DIR})
endif()
-diff -ru multicoreware-x265-d6257335c537/source/common/CMakeLists.txt patched/source/common/CMakeLists.txt
---- multicoreware-x265-d6257335c537/source/common/CMakeLists.txt 2014-07-09 10:25:15.000000000 +0200
-+++ patched/source/common/CMakeLists.txt 2014-07-11 02:32:59.046579781 +0200
-@@ -117,10 +117,16 @@
- source_group(Assembly FILES ${ASM_PRIMITIVES})
- endif(ENABLE_ASSEMBLY)
+ if(LINKER_OPTIONS)
+ # set_target_properties can't do list expansion
+diff -ruN x265_2.5/source/common/CMakeLists.txt patched/source/common/CMakeLists.txt
+--- x265_2.5/source/common/CMakeLists.txt 2017-07-13 13:20:07.000000000 +0200
++++ patched/source/common/CMakeLists.txt 2017-08-17 17:02:32.291048935 +0200
+@@ -116,10 +116,16 @@
+ string(REPLACE ";" " " VERSION_FLAGS "${VFLAGS}")
+ set_source_files_properties(version.cpp PROPERTIES COMPILE_FLAGS ${VERSION_FLAGS})
-check_symbol_exists(strtok_r "string.h" HAVE_STRTOK_R)
-if(HAVE_STRTOK_R)
@@ -33,12 +35,12 @@ diff -ru multicoreware-x265-d6257335c537/source/common/CMakeLists.txt patched/so
if(GCC AND CC_HAS_NO_NARROWING)
set_source_files_properties(cpu.cpp PROPERTIES COMPILE_FLAGS -Wno-narrowing)
-diff -ru multicoreware-x265-d6257335c537/source/common/param.cpp patched/source/common/param.cpp
---- multicoreware-x265-d6257335c537/source/common/param.cpp 2014-07-09 10:25:15.000000000 +0200
-+++ patched/source/common/param.cpp 2014-07-11 02:36:54.809974684 +0200
-@@ -28,6 +28,9 @@
+diff -ruN x265_2.5/source/common/param.cpp patched/source/common/param.cpp
+--- x265_2.5/source/common/param.cpp 2017-07-13 13:20:07.000000000 +0200
++++ patched/source/common/param.cpp 2017-08-17 17:02:32.291048935 +0200
+@@ -29,6 +29,9 @@
+ #include "cpu.h"
#include "x265.h"
- #include "TLibCommon/TComSlice.h"
+//FIXME For strtok_r in Mingw-w64 (see CMakeLists.txt)
+#include <pthread.h>