summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-06-11 14:13:13 -0400
committerPatrick Northon2020-06-11 14:13:13 -0400
commit7011cfe8e6ffa4beab649d265ddc3c65ebb15ea0 (patch)
treedf3669fda7d2c8f89f10e5f45d9060af84bde477
parentd8240cabdecc936605e55165f2686bf0996d4d7f (diff)
downloadaur-7011cfe8e6ffa4beab649d265ddc3c65ebb15ea0.tar.gz
Update pkgver.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9a120f878e7..fc89875bd7f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-xalan-c-git
pkgdesc = The Apache Xalan-C++ Project provides a library and a command line program to transform XML documents using a stylesheet that conforms to XSLT 1.0 standards.
- pkgver = 1.12.0
+ pkgver = r2.d8240ca
pkgrel = 1
url = https://xalan.apache.org/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 842d52adfe30..dd3896806be4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mingw-w64-xalan-c-git
conflicts=("mingw-w64-xalan-c")
provides=("mingw-w64-xalan-c")
-pkgver=1.12.0
+pkgver=r2.d8240ca
pkgrel=1
pkgdesc="The Apache Xalan-C++ Project provides a library and a command line program to transform XML documents using a stylesheet that conforms to XSLT 1.0 standards."
arch=(any)
@@ -20,6 +20,14 @@ sha256sums=(
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd "${_repo}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
prepare() {
cd "xalan-c"
git apply "../fix-cross-compile.patch"