summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-06-07 14:33:57 -0400
committerPatrick Northon2020-06-07 14:33:57 -0400
commit8e2cb535f860604da390285863482235463dd4e2 (patch)
tree327c443a9da44a23c59c45feda7d665e14d6c9dc
downloadaur-8e2cb535f860604da390285863482235463dd4e2.tar.gz
Initial commit.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD46
-rw-r--r--fix-cross-compile.patch50
3 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b73dff784e73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = mingw-w64-xalan-c-icu
+ pkgdesc = The Apache Xalan-C++ Project provides a library and a command line program to transform XML documents using a stylesheet that conforms to XSLT 1.0 standards. (ICU enabled)
+ pkgver = 1.12.0
+ pkgrel = 1
+ url = https://xalan.apache.org/
+ arch = any
+ license = APACHE
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-wine
+ makedepends = git
+ depends = mingw-w64-crt
+ depends = mingw-w64-xerces-c-icu
+ depends = mingw-w64-icu
+ provides = mingw-w64-xalan-c
+ conflicts = mingw-w64-xalan-c
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/apache/xalan-c/archive/Xalan-C_1_12_0.tar.gz
+ source = fix-cross-compile.patch
+ sha256sums = f3d4f23af7f7914259f2f5dbd9cc1450d3ebe0b8c8163fd50fcac4a39c63fccd
+ sha256sums = 67ab886be3737b39816ab4b7cead15077fcd4808f5d991747343d8485013642a
+
+pkgname = mingw-w64-xalan-c-icu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..471dc67ec70f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+pkgname=mingw-w64-xalan-c-icu
+provides=("mingw-w64-xalan-c")
+conflicts=("mingw-w64-xalan-c")
+pkgver=1.12.0
+pkgrel=1
+_filever="1_12_0"
+pkgdesc="The Apache Xalan-C++ Project provides a library and a command line program to transform XML documents using a stylesheet that conforms to XSLT 1.0 standards. (ICU enabled)"
+arch=(any)
+url="https://xalan.apache.org/"
+license=("APACHE")
+makedepends=('mingw-w64-cmake' 'mingw-w64-wine' 'git')
+depends=('mingw-w64-crt' 'mingw-w64-xerces-c-icu' 'mingw-w64-icu')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("https://github.com/apache/xalan-c/archive/Xalan-C_${_filever}.tar.gz"
+ "fix-cross-compile.patch")
+sha256sums=(
+ "f3d4f23af7f7914259f2f5dbd9cc1450d3ebe0b8c8163fd50fcac4a39c63fccd"
+ "67ab886be3737b39816ab4b7cead15077fcd4808f5d991747343d8485013642a")
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "xalan-c-Xalan-C_${_filever}"
+ patch -uNp1 < "../fix-cross-compile.patch"
+ sed -i -r "s/_MSC_VER/_WIN32/" "src/xalanc/XalanExe/XalanExe.cpp"
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ #${_arch}-cmake -S "xalan-c-Xalan-C_${_filever}" -B "build-${_arch}-static" -Dtranscoder=icu -DCMAKE_BUILD_TYPE=Release -Ddoxygen=OFF -DBUILD_SHARED_LIBS=FALSE
+ ${_arch}-cmake -S "xalan-c-Xalan-C_${_filever}" -B "build-${_arch}" -Dtranscoder=icu -DCMAKE_BUILD_TYPE=Release -Ddoxygen=OFF
+ make -C "build-${_arch}"
+ make -C "build-${_arch}"
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ #make DESTDIR="${pkgdir}" -C "build-${_arch}-static" install
+ make DESTDIR="${pkgdir}" -C "build-${_arch}" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
diff --git a/fix-cross-compile.patch b/fix-cross-compile.patch
new file mode 100644
index 000000000000..95218c07ffa7
--- /dev/null
+++ b/fix-cross-compile.patch
@@ -0,0 +1,50 @@
+diff --git a/src/xalanc/Include/XalanVersion.hpp.in b/src/xalanc/Include/XalanVersion.hpp.in
+index d0a7d97..63911ed 100644
+--- a/src/xalanc/Include/XalanVersion.hpp.in
++++ b/src/xalanc/Include/XalanVersion.hpp.in
+@@ -26,11 +26,11 @@
+ #define XALANVERSION_HEADER_GUARD_1357924680
+
+ /// Xalan-C major version.
+-#define XALAN_VERSION_MAJOR (@xalan-c_VERSION_MAJOR@)
++#define XALAN_VERSION_MAJOR @xalan-c_VERSION_MAJOR@
+ /// Xalan-C minor version.
+-#define XALAN_VERSION_MINOR (@xalan-c_VERSION_MINOR@)
++#define XALAN_VERSION_MINOR @xalan-c_VERSION_MINOR@
+ /// Xalan-C patch version.
+-#define XALAN_VERSION_REVISION (@xalan-c_VERSION_PATCH@)
++#define XALAN_VERSION_REVISION @xalan-c_VERSION_PATCH@
+
+ /**
+ * Xalan-C++ version represented as a single integer value.
+diff --git a/src/xalanc/Utils/CMakeLists.txt b/src/xalanc/Utils/CMakeLists.txt
+index dc39ad0..78b6160 100644
+--- a/src/xalanc/Utils/CMakeLists.txt
++++ b/src/xalanc/Utils/CMakeLists.txt
+@@ -41,13 +41,22 @@ add_custom_target(locale ALL)
+ set_target_properties(locale PROPERTIES FOLDER "Message Library")
+
+ if(msgloader STREQUAL "inmemory")
++ set(MsgCreatorCommandFilename "${XLIFF_FILE_NAME}")
++ set(MsgCreatorCommand "$<TARGET_FILE:MsgCreator>" -TYPE inmem -LOCALE ${LOCALE})
++
++ if(CMAKE_CROSSCOMPILING_EMULATOR)
++ set(MsgCreatorCommand "${CMAKE_CROSSCOMPILING_EMULATOR}" "${MsgCreatorCommand}")
++ if(WIN32)
++ set(MsgCreatorCommandFilename "Z:${MsgCreatorCommandFilename}")
++ endif()
++ endif()
++
++ set(MsgCreatorCommand "${MsgCreatorCommand}" "${MsgCreatorCommandFilename}")
++
+ add_custom_command(
+ OUTPUT "${GENMSGINDEX}"
+ "${GENMSGDATA}"
+- COMMAND "$<TARGET_FILE:MsgCreator>"
+- "${XLIFF_FILE_NAME}"
+- -TYPE inmem
+- -LOCALE ${LOCALE}
++ COMMAND ${MsgCreatorCommand}
+ WORKING_DIRECTORY "${XSL_NLS_GEN_DIR}"
+ COMMENT "Generating inmemory locale message data"
+ DEPENDS MsgCreator "${XLIFF_FILE_NAME}")