summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Staal2015-08-24 10:20:45 +0200
committerJens Staal2015-08-24 10:20:45 +0200
commit11cf7c86743de62541f2ebd53f98a4e33e5feeee (patch)
treeca43d4f68eae5b50314caf549103768267859a1e
parent88b7a43bfdcb3cde6acc9a4581a9fe927e6693b3 (diff)
downloadaur-11cf7c86743de62541f2ebd53f98a4e33e5feeee.tar.gz
upgrade xcb-proto to git
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 628fbee4e13a..477b233de37b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = mingw-w64-xcb-proto
pkgdesc = XML-XCB protocol descriptions (mingw-w64)
- pkgver = 1.11
+ pkgver = 1.11.r95.g6b832a0
pkgrel = 1
url = http://xcb.freedesktop.org/
arch = any
license = custom
makedepends = python
makedepends = libxml2
- source = http://xcb.freedesktop.org//dist/xcb-proto-1.11.tar.bz2
- sha256sums = b4aceee6502a0ce45fc39b33c541a2df4715d00b72e660ebe8c5bb444771e32e
+ makedepends = git
+ source = xcb-proto::git://git.freedesktop.org/git/xcb/proto
+ sha256sums = SKIP
pkgname = mingw-w64-xcb-proto
diff --git a/PKGBUILD b/PKGBUILD
index 3fb4f50e379f..e2cf811707fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,27 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=mingw-w64-xcb-proto
-pkgver=1.11
+pkgver=1.11.r95.g6b832a0
pkgrel=1
pkgdesc="XML-XCB protocol descriptions (mingw-w64)"
arch=(any)
url="http://xcb.freedesktop.org/"
license=('custom')
-makedepends=('python' 'libxml2')
-source=($url/dist/xcb-proto-$pkgver.tar.bz2)
-sha256sums=('b4aceee6502a0ce45fc39b33c541a2df4715d00b72e660ebe8c5bb444771e32e')
+makedepends=('python' 'libxml2' 'git')
+source=("xcb-proto::git://git.freedesktop.org/git/xcb/proto")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/xcb-proto"
+ git describe --long | sed 's/-/.r/;s/-/./g'
+}
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd xcb-proto-$pkgver
+ cd xcb-proto
+ ./autogen.sh
+ make distclean
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure
@@ -28,9 +35,9 @@ build() {
}
package() {
- cd xcb-proto-$pkgver
+ cd xcb-proto
for _arch in ${_architectures}; do
- cd "${srcdir}/xcb-proto-${pkgver}/build-${_arch}"
+ cd "${srcdir}/xcb-proto/build-${_arch}"
make DESTDIR="$pkgdir" install
done
}