summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-09-16 13:55:16 +0200
committerMichel Zou2017-09-16 13:55:16 +0200
commit204f2022864c9e98c940af87bb5121950f31d8c4 (patch)
treee83b7bf4bd7678f369c7120211b12fd562946243
downloadaur-204f2022864c9e98c940af87bb5121950f31d8c4.tar.gz
r2384
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD45
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba3d7c7c4007
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sat Sep 16 11:55:16 UTC 2017
+pkgbase = mingw-w64-xdmf-git
+ pkgdesc = eXtensible Data Model and Format (mingw-w64)
+ pkgver = r2384.605db515
+ pkgrel = 1
+ url = http://www.xdmf.org
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-boost
+ depends = mingw-w64-hdf5
+ depends = mingw-w64-libxml2
+ depends = mingw-w64-libtiff
+ provides = mingw-w64-xdmf
+ conflicts = mingw-w64-xdmf
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = git+git://xdmf.org/Xdmf.git
+ sha256sums = SKIP
+
+pkgname = mingw-w64-xdmf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c67647ea1665
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+
+pkgname='mingw-w64-xdmf-git'
+pkgver=r2384.605db515
+pkgrel=1
+pkgdesc="eXtensible Data Model and Format (mingw-w64)"
+arch=('any')
+url="http://www.xdmf.org"
+license=('BSD')
+depends=('mingw-w64-hdf5' 'mingw-w64-libxml2' 'mingw-w64-libtiff')
+makedepends=('mingw-w64-cmake' 'mingw-w64-boost')
+provides=('mingw-w64-xdmf')
+conflicts=('mingw-w64-xdmf')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("git+git://xdmf.org/Xdmf.git")
+sha256sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+pkgver() {
+ cd "$srcdir/Xdmf"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd Xdmf
+}
+
+build() {
+ cd Xdmf
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/Xdmf/build-${_arch}
+ make DESTDIR="$pkgdir/" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}